Unable to view the users on the Admin Portal
No user or control button is shown under Users tab in User Management page. It is also noted that users are not shown at User's View > Collection > Add Users > dropdown list.

Error message
Gallery log records the message like this.
“2021-12-15 22:01:42.495625,ERROR,92,ErrorHandler,HandleError,70334be8eb754bbd87da9a8971fe606a,600e609867334a14b455ddd8,10.10.10.123,gallery_hostname,"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.93 Safari/537.36",GET,/gallery/api/admin/users/,500,89,Exception caught by ErrorHandler and marshaled to client,"System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.FormatException: An error occurred while deserializing the AccountLockedAt property of class Alteryx.Server.Models.BaseModels.User: String was not recognized as a valid DateTime.”
Environment
Cause
One of the accounts had an invalid value in the "AccoutLockedAt" field in MongoDB.
Spoilers
We saw that a SAML authentication system set the invalid value "Sun Oct 10 2021 22:25:50 GMT+00:00 (Coordinated Universal Time)" into the "AccountLockedAt" field after the account was locked.
Resolution
Replace the value of "AccountLockedAt" to "null" as well as "NumFailedLogins" and "AccountLocked"
PLEASE NOTE: Making direct edits to the database is only for advanced users. You must have a database backup in place prior to making any changes. If you would like assistance with the manual database edits, please contact
Alteryx Support .
- Connect to the AlteryxGallery database using Robo 3T (See article to connect to Robo 3T).
- Once you connect to Robo 3T, expand AlteryxGallery, expand Collections, double-click users.
- Run the following commands to find the user records with null/incorrect values:
db.users.find({ $and : [ { "AccountLockedAt" : { $not : { $type : 9 } } }, { "AccountLockedAt" : { $ne : null } } ] })
- Right-click each document (identified from above) and click Edit Document...
- Replace the value of "AccountLockedAt" to "null" or a valid value, for example "ISODate("2021-12-24T11:38:44.311+0000")".
- Click the Validate button in the bottom-left corner to ensure the data is entered in proper JSON format.
- Click Save
- Repeat this for all necessary documents.
Additional Resources