02-07-2019 12:38 PM - edited 08-03-2021 02:09 PM
Issue
When running a workflow that uses the Dynamics CRM Input/Output or PowerBI Output tool(s), the following error is seen:
AttributeError: 'AzureActiveDirectoryWebApplicationClient' object has no attribute 'populate_token_attributes'
Full error text:
Error: Power BI Output (3): Traceback (most recent call last): File "C:\ProgramData\Alteryx\Tools\power_bi_output_v2.1.1\power_bi_output\connections.py", line 84, in ii_init token_updater=self._update_token File "C:\ProgramData\Alteryx\Tools\power_bi_output_v2.1.1\Lib\site-packages\requests_oauthlib\oauth2_session.py", line 69, in __init__ self.token = token or {} File "C:\ProgramData\Alteryx\Tools\power_bi_output_v2.1.1\Lib\site-packages\requests_oauthlib\oauth2_session.py", line 119, in token self._client.populate_token_attributes(value) AttributeError: 'AzureActiveDirectoryWebApplicationClient' object has no attribute 'populate_token_attributes'
Error: Dynamics CRM Input (1): Traceback (most recent call last): File "C:\ProgramData\Alteryx\Tools\dynamics_crm_input_v1.0.2\dynamics_crm_input\engine.py", line 132, in pi_push_all_records alteryx_engine=self.alteryx_engine File "C:\ProgramData\Alteryx\Tools\dynamics_crm_input_v1.0.2\connectors_core\dynamics\crm.py", line 62, in __init__ token_updater=self._update_token File "C:\ProgramData\Alteryx\Tools\dynamics_crm_input_v1.0.2\Lib\site-packages\requests_oauthlib\oauth2_session.py", line 69, in __init__ self.token = token or {} File "C:\ProgramData\Alteryx\Tools\dynamics_crm_input_v1.0.2\Lib\site-packages\requests_oauthlib\oauth2_session.py", line 119, in token self._client.populate_token_attributes(value) AttributeError: 'AzureActiveDirectoryWebApplicationClient' object has no attribute 'populate_token_attributes'
Environment
Cause
During the installation of the tool, a newer version of the requests-oauthlibPython package was downloaded. This tool requires a specific version in order to function properly. This is currently a defect (DE18610) that will be fixed in future versions of the tool(s).
Solution
Edit the requirements.txt file to the necessary version, then reinstall the tool. Please first remove any previously installed tools from your machine. They can be found in either:
Solution B
1. If you are unable to get the above steps to work, please open a support ticket in the Case Portal.
This resolved my issue! Thank you...
This help me. Resolved, thank you!
This was resolved for PowerBI in Version 2.1.2 of the tool and above. Still applicable to the Dynamics CRM tool.
Any updates on when this will be resolved for DynamicsCRM?