The Product Idea boards have gotten an update to better integrate them within our Product team's idea cycle! However this update does have a few unique behaviors, if you have any questions about them check out our FAQ.

Alteryx Designer Desktop Ideas

Share your Designer Desktop product ideas - we're listening!
Submitting an Idea?

Be sure to review our Idea Submission Guidelines for more information!

Submission Guidelines

In Database for MySQL

Not sure what detail needs to be added.  This is obviously a widely used RDBMS.

13 - Pulsar


Good point, MySQL ranks second more popular than MS SQL Server..

Looking forward for In-db addition, basic queries can already be prepped as push through and

there already is an R package for accessing Mysql from R...








Alteryx Alumni (Retired)
Status changed to: Accepted

Hi All,


Thanks for the feedback. We're hoping to get this in H1 next year.




Alteryx Alumni (Retired)
Status changed to: Under Review
Alteryx Alumni (Retired)
Status changed to: Implemented

This was released in 18.2

11 - Bolide


8 - Asteroid

So, I have found that there is INDB support for MySQL, and I'm attempting to use it, but I'm plagued with syntax errors if I use any INDB tool other than a SELECT. Sample tools, formula... everything I've tried on a very simple connection all result in a syntax error. 

I'm using a native MySQL 8 driver (that I got on Alteryx's driver site (which I think directed me to mySQL directly)); I also have a version using the Simba driver. Either way, I get the same error: 
"Error: Connect In-DB (11): Error SQLPrepare: [MySQL][ODBC 8.0(a) Driver][mysqld-5.7.12]No database selected" I see this error in a INDB Browse tool.

Of course I have tested using the browser with a normal input tool; that works fine. I have also tested the query in a SQL window--that works fine too (nut it is a different driver, unfortunately). 

That mysqld-5.7.12 makes me itchy--is it looking for a MySQL 5 driver?

Does anyone know why I can't use INDB functionality within MySQL?