The Product Idea boards have gotten an update to better integrate them within our Product team's idea cycle! However this update does have a few unique behaviors, if you have any questions about them check out our FAQ.

Alteryx Designer Desktop Ideas

Share your Designer Desktop product ideas - we're listening!
Submitting an Idea?

Be sure to review our Idea Submission Guidelines for more information!

Submission Guidelines

Set data type in Text Input tool

Idea: Allow the user to set the data type including character field width in the Text Input tool.


The Text Input tool currently auto-senses the correct type and width of the field in a Text Input tool. However, this sometimes restricts the usage of the data downline.



1 - I often run into the situation where I've copied some data from a browse tool and then pasted that as an input to a new workflow. Then I'll turn that workflow into a macro. But then I run into an issue where the data that comes into the macro is larger than the original width in the Text Input tool. This causes problems.


2 - The tool senses that a field containing zip codes should be numeric and then converts the data. This corrupts the data and makes me insert a Select/Formula tool combo to pad the zeros to the left.

5 - Atom

Is there a work around for this right now? 
How can we achieve this using a different tool right now in Alteryx?


8 - Asteroid

Is there any update on this issue?  I currently need to be able to change a data type for my text input tool to work.  Any direction, very much appreciated !

5 - Atom

I'd appreciate some update as well. This thread is 4 year old and still nothing in Alteryx ? I am on version 2019.3

8 - Asteroid

This is also a problem for me, very hard to get these bool fields back to strings.  Affects the macro input tool as well.  I need nulls to flow through without converting to Bool.  And when using the select tool to change field type, I have to manually change the width for each field individually (no way to change the widths to a selection of fields).   I hopefully found a workaround with a multi field formula tool.  Select all incoming "bool" fields, and change the output type to "V_WString and set your own size.  Enter "CurrentField" as the formula.

8 - Asteroid

Under review since 4 years now. Must be many people facing this issue. Any updates?

11 - Bolide

Hi I also have this problem and would appreciate the text input tool allowing data types to be chosen. This also gets wonky for a Macro Input tool - the "Text Input" selection fpor the template which allows you to test your workflow doesn't play nicely if you intend to pass in text. Currently my workaround is to type a bunch of gibberish into the Text Input to seed the metadata with a string that is hopefully long enough to accommodate how large that field might be. Even though that "Text Input" option for the Macro Input tool is intended for testing, it has direct impacts on the rest of the macro. 




11 - Bolide

Just came here to suggest this if it wasn't already.  I picture something like the bonus settings for some actions in the summarize tool, at the bottom of the configuration screen when the field is selected.  This would be super useful!  

8 - Asteroid

Three years later... any news?


Surely easiest solution from backwards compatibility would be to have a new tool called 'Manual Input' until ye olde 'Text Input' is eventually deprecated...?

5 - Atom

Apologies in advance if this doesn't help, I am new user (Day 1) and I ran into this issue while getting familiar with the tool.  I believe the solution is using the 'Select' tool under the Preparation Ribbon.  I was able to workflow the 'Text Input' into the 'Select' tool and convert a 'byte' type into a 'Int32'.  

8 - Asteroid

Seems this has been under review for some time now. I'm still keen on this feature!!