The Product Idea boards have gotten an update to better integrate them within our Product team's idea cycle! However this update does have a few unique behaviors, if you have any questions about them check out our FAQ.

Alteryx Designer Desktop Ideas

Share your Designer Desktop product ideas - we're listening!
Submitting an Idea?

Be sure to review our Idea Submission Guidelines for more information!

Submission Guidelines

Publish to Tableau Server Macro - caching yxdb unique filename

We are running into errors on our scheduler if we have multipe workflows with the Publish to Tableau server macro running at the same time. The macro writes to a local yxdb file with a fixed naming convention and is locked if another workflow is using it at the same time.  We like to see if the cached filename TableauServer.Selection.ServerSite.yxdb can be made somehow unique.  

Error experience: 



Talking with support this is a known issue and needs Macro enhancement.

7 - Meteor

was this issue resolved - we are running into a similar error where it says 'Error creating the file ".<file path>\TableauServer.Selection.ServerSite.yxdb" Access is denied'


also wondering if you guys worked around this somehow ?

5 - Atom

I run into the same issue and was able to resolve when running my workflow as Administrator.

Recently I also found out that if you disable "Save connection history" checkbox under "Connection" tab then it is also working with non-admin access.

Status changed to: Inactive

The status of this idea has been changed to 'Inactive'. This status indicates that:


1. The idea has not had activity in the form of likes or comments in over a year.

2. The idea has not reached ten likes.

3. The idea is still in the 'New Idea' status. 


However, this doesn't mean your idea won't be implemented! The Community can still like and comment on this idea. With enough renewed interest, this idea can be brought back into the 'New Idea' status. 


Thank you for contributing to the Alteryx Community and the Alteryx Product Idea Boards!

13 - Pulsar
13 - Pulsar

Hey @KylieF - Looks like this is a bug which has been fixed with updates or administrator workaround, so can probably be moved or marked as implemented.

Alteryx Community Team
Alteryx Community Team
Status changed to: Implemented

Thank you for the ping Joe!


I'll update this to implemented since this is an older idea from before we more clearly defined and separated bugs from ideas. But this issue has been corrected in all currently supported versions of Alteryx.