Alteryx Server

Find answers, ask questions, and share expertise about Alteryx Server.

Scheduled workflow run successfully but no output produced

Highlighted
8 - Asteroid

Hi

 

I am currently facing an issue that I have schedule workflow to run, and it has run successfully but no output has been produced.

 

If i run it in the designer manually, the output has produced fine.

 

Any Idea?

 

Thanks

 

Highlighted
16 - Nebula

Are you using any mapped drive letters in paths for inputs or outputs? Is there any info in the Outputlog?

Highlighted
8 - Asteroid

Hello

 

I am using a structure to create dynamic input and output path, \03. JSONS\yyyymm\31. Compliance\UAT\giftsAndEntertainment.Quarterlytrend.yyyymm.Json. and the yyyymm will be replaced by the parameter to pass through in.

 

in the outputlog, there is no message about where the output been write to. However, if i run it in the designer, i can see there is type of message called "Files" which it show where the output been write to.

 

Thanks

 

Chunbin 

Highlighted
16 - Nebula

Can you post a screenshot of the Output Data tool configuration and the output path from the workflow results when you run it manually.

Highlighted
8 - Asteroid

Hi

 

i have attached 2 screenshot as i did test for output.

the first one: output successes is where i manually type the output path in a text tool then connect with output data tool directly. then it produced output correctly.

 

Second one: output failed is where the output generated dynamically by using formula tool, and output the result by using output data tool. and this is the one that failed and want to fix.

 

Thanks

Highlighted
16 - Nebula

The way I would test this is to build the formula 1 step at a time, so start with just putting the static path and filename in your formula tool, like this:

 

DavidP_0-1589195704257.png

Then change it to use the dynamic [yyyyMM] field and test again

 

DavidP_1-1589195929467.png

Once this is working correctly, change your formula to an if statement and test again.

 

It could be something like the folder [yyyyMM] does not exist or is not in the format you expect, or the if statement is not behaving like you're expecting.

 

 

Highlighted
8 - Asteroid

HI @DavidP 

 

As you have suggested, i have tried both method and they are not working at all.

 

Therefore i have tried to add an extra output tool from beginning of reading the file till the output. Surprisingly, none of the part of process has contains any data.

 

any idea?

 

Thanks

 

CHunbin 

Highlighted
16 - Nebula

Can you share a version of the workflow for me to look at?

Highlighted
8 - Asteroid

HI @DavidP 

 

Please find the attachment of the WF.

 

Thanks

 

Chunbin