Alter.Nation

Community news, customer stories, and more!
baileykaplan
Moderator
Moderator

Hey there Alteryx Developers, we’re upgrading Python 3.8.16 to 3.10.13.

 

Python Upgrade: Why the Hiss?


Security is paramount at Alteryx and to stay ssssecure (see what we did there?) and compliant, we are upgrading Designer and Server to Python 3.10 for the 2024.1 release in early May. Designer tools that haven't been upgraded will not work in 24.1, thus we’re requesting that partners and customers upgrade their tools in advance of the release.

 

Who's Affected?

 

Now, you might be wondering, "Is this upgrade going to rattle my workflow?" This upgrade primarily affects those who have created or are using custom tools built with the Python Engine or V2 SDKs. Users of the Python tools and Insights tools may also be affected by this change, as well as Alteryx-built SDK tools (such as the ML tools, Auto Insights tools, AIS tools, and Workflow Utilities tools).  Additionally, Server customers who prefer to test new workflows in a single sandbox environment may want to create a separate sandbox environment for testing 24. 1.

 

Don’t Get Bitten – Act Now

 

Here's what you need to do to ensure a smooth transition:

 

  • Upgrade Your Tools: If you've built custom tools with the Python Engine or V2 SDKs, it's time to upgrade them to Python 3.10.13. This ensures compatibility with Designer and Server 24.1 and keeps your workflow flowing smoothly. Follow the step-by-step instructions on Alteryx IO for a comprehensive upgrade guide, testing information, and troubleshooting tips.

 

  • Redistribute Your Tools: Once you've upgraded your tools, make sure to repost them on Community Gallery or Marketplace. Let's make sure everyone has access to the latest and greatest versions!

 

 

We're committed to making this transition as smooth as possible for all our users. Remember, we're here to help. Stay tuned for more updates, and until next time, happy upgrading!

 

Ssssincerely, The Alteryx IO Team 🐍🔍