Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Macro issues with "Field schema changed between iterations"

5 - Atom



I ran into an error which says "the field schema for the output changed between iterations” when I was running a macro to process two excel files. The structure and field types seem to be same between these two, and the only difference is the fiscal year (FY17 vs. FY18). I'm not sure why it says Field schema changed. I've attached the Alteryx workflows and source files - could someone take a look and let me know what went wrong? Thanks in advance!




7 - Meteor

@jlowe1 When I was testing my workflow I didn't have anything connected to the output anchor of my macro. After attaching a "Select" tool to the output, it returned a result set that I expected. I'm not sure why this fixed the issue but it did. Hopefully this simple fix will apply to you as well. 

5 - Atom

Oh that's great - that has worked! How bizzare, thank you! 

7 - Meteor

In the calling job (job calling the macro), please specify the Input file as  *.xlsx in the path to read through all the files in the folder



5 - Atom

HI all, I was having the same issue and found this thread, however the fix did not work for me. Any reason as to why? 

7 - Meteor

@jasperlch thankyou for this solution.

I have a macro specifically designed to get the file schema for all the File|Sheets feed into it.  The macro transposes the first row of data, and it returns 3 fields

  • FileNameSheet,
  • Name (which is the Sheet column F1, F2, F3 etc), and
  • Value (name from the 1st selected row, which should be the Field name in the schema for the FileNameSheet).

This should work regardless of the schema in any sheet, yet it was returning an error (even though the output was identical if the files are run separately.  You solution fixed my problem.

9 - Comet

I dont have a properties tab for my macro output. I know this is 4 years later but same issue here.


EDIT: Thanks @anhvolmer you helped this