The Inspire Cyber Monday promo has been extended to Dec. 1! This offer is discounted off the Early Bird price and includes 20% off for conference-only passes and 10% off training passes.

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Error : Publish to tableau server - select an existing project

6 - Meteoroid



I'm having an issue with the Publish to Tableau server tool version 2.0.0 (using Alteryx 2018.2 and Tableau server 2018.1)


I've installed it from the official gallery. I've signed in to the Tableau server without problem, then went to the "Configure Data Source" part. I can see the projects, I can enter a data source name, choose the output options and data source format . everything is fine. When I validate, I get an error message "Select an existing project".


Of course the workflow won't run.. but I can't access the configuration anymore. There is a  spinning circle that never stops and the configuration panel is not accessible. All I can do is deleting the object from the workflow.


I've installed previous versions of the tool. So just after dropping it on my canvas, I can right click and select the version (1.09.2 or 1.08.1). Both versions work and allow me to publish to the server, in .tde or .hyper, which is what I want...


Maybe a next version will solve this issue, but if there is a solution to it, I would be interested in knowing it.


thank you

5 - Atom



Has anyone managed to solve this issue yet? 

6 - Meteoroid

Not that I am aware of. However the older version did work for me (1.09.2).

When downloading the tool you can choose which version you would like to download and install. Select and install 1.09.2. You can have multiple versions installed. In your flow right click the publish to tableau tool and just above open macro you have the 'choose tool version' option. You can select 1.09.2 there.

Hello @Gudo thanks for suggestion to use old version v1.09.2.  I could not find the location you mentioned to 'choose tool version' option.


For those who are also looking for it, now I found it by these specific steps:

  - right click the tool

  - choose open macro

  - in the macro, click the canvas and choose the tab "Meta Info"

  - here you can find the 'choose tool version'


So, for me since I could not find it, I just deleted all the instances of this macro from the filesystem.  And then I installed v1.09.2


Now the old version of the macro is working correctly.



I am quite bummed about this because:

   - it consumed 1 hour of my time

   - the problem has been open for 8 months now

   - Alteryx is headline sponsor at the Tableau conference

   - this tool is written and supported by Alteryx themselves

   - the tool seems like basic functionality, should simply work correctly, without detailed troubleshooting


Hello Alteryx,


Can you please let us know, what are the plans to get the v2.0.0 tool working again?






8 - Asteroid

Has anyone found a fix for this? Having the same issue.


Hi Jinesh,


When I checked with Alteryx dev team, they said "Yes, the customer should revert to a previous version of the Publish to Tableau tool. A defect (DE16655) is being worked on to fix the issue, but we don't have an ETA on that.”


You can follow my instructions earlier in this post on how to do that.


Hope this helps!


7 - Meteor

Any update on a solution from Alteryx? The latest version of the tool has the ability to reference previous Tableau data source metadata when overwriting a previous data source and will definitely be excited to use that feature once the tool is stable. 

5 - Atom

 I'm getting this too


Hi everyone, My understanding from Alteryx support is that this defect (DE16655) is scheduled to be fixed for the next release (2019.2).


Alteryx Alumni (Retired)

@action-analytics @Philimor @KaiC @fdelapena @jineshnp31 @agathacosta @Gudo @Alexios81 @CliveM @Julien_B @A1 @Shaunavalon @tim_moore_tx @lisebohr 


If you are feeling intrepid, version 2019.2 is now available for you to try with the Publish to Tableau Server tool v2.0.0.

(Publish to Tableau Server tool v1.09.02 is still available from the Gallery.  As others have pointed out, you can choose the tool version by right-clicking on the tool.)



Lisa LePome
Principal Support Engineer -- Knowledge Management Coach
Alteryx, Inc.
6 - Meteoroid



I tried today. I can configure the connection to the server and then select the project, data source, output options and format. But when I validate the tool, I got the same error "select an existing project" under the tool icon on the canvas. And when I try to get back to the configuration, it doesn't wok :




I must say that it's boring. Working more and more with Tableau server, this is becoming a real limitation.