Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Run Batch File from Alteryx Gallery to trigger QlikView QMSEDX

prashantkumar
5 - Atom

Hi There,

 

So, i am trying to run 2 batch files from Alteryx Gallery

  1. For moving files
  2. to trigger auto-reload of QlikView Dashboard using QMSEDX

Alteryx Server (single node) is separate --> QlikView Server (single node) is separate (all ports and protocols are in place)

 

The workflow run fine when I RDP into Alteryx server and run it and the batch files run on the QlikView server as well from the Alteryx server.

 

But, when I create a package (.yxzp) and upload it on Alteryx Gallery, 1st batch file runs (moves files successfully) but 2nd one doesn't trigger auto-reload of QlikView dashboard.

 

There is no error and the workflow just keeps on running till countdown of 10 like below - 

Job Status: Running
Retry Attempt: 6

Results will appear when the Workflow is finished running.

 

and then shows this - 

 

We are unable to get the status of your workflow results at this time. You can close this view and check the Workflow Results page later.

 

When I check the workflow results page, it gives below - 

Unknown error. ArgumentException RequestID: 72433d998244463ab1fbee4bf9d3ad32

 

Am I doing something wrong?

 

Copy.bat file has below command - 

echo D | xcopy /S /I /Q /Y /F "\\QlikViewServer\QlikViewDashboardFiles\ExecDashboard\L1 Output\*.*" "\\QlikViewServer\QlikViewDashboardFiles\ExecDashboard\QV Input"

 

Trigger.bat file has below command - 

\\QlikViewServer\QlikViewDashboardFiles\ExecDashboard\QMSEDX\QMSEDX.exe -task="Reload and Distribute of ExecDashboard\Executive Dashboard - Redesigned-Live.qvw" -qms="http://QlikViewServer:4799/QMS/Service"

 

Any help would be highly apriciated.

 

Thanks,

Prashant

6 REPLIES 6
hroderick-thr
10 - Fireball

When you run on the server, can you use the same credentials as gallery?

 

Could you put both commands into one bat file?

 

Are you using run command tool or event?

 

Can you make the black cmd window appear and add a pause statement to the end to debug?

 

Try putting 'call ' at the beginning of your commands...

call xcopy...   

call \\QlikViewServer\QlikViewDashboardFiles\ExecDashboard\QMSEDX\QMSEDX.exe...

prashantkumar
5 - Atom

Hi hroderick-thr,

 

Thank you so much for taking out time to reply to my question.

 

Yes, I use same credentials for RDP into Alteryx server and Alteryx Gallery, and both the commands are into a single bat file and I am using the command tool for QMSEDX. So I don't think this will be issue of creds.

 

When I run it from server the cmd window pops up, waits for 2 min and the reload of QlikView starts, because it triggers the reload of QlikView dashboard, I never thought of using pause statement because there was nothing to debug. Would you recommend using pause when trying to run from Alteryx Gallery?

 

As suggested, I tried call before each commands, but same thing, copying works but not the QMSEDX.

 

hroderick-thr
10 - Fireball

Try...

RDP to the server that runs the problem bat file.

Open a cmd window

Copy/paste the commands from bat file to cmd window.

You may need to press enter so the last line will run.

Examine output for indication of problems.

prashantkumar
5 - Atom

So I tried it, and it run without any issue and triggers the reload as well.

 

Somehow when I upload it on Alteryx Gallery, it doesn't work, the first part work (moving files) but the QMSEDX dosen't work from Alteryx Gallery

 

I am at my wits end here 😞

prashantkumar
5 - Atom

thanks, it worked 🙂

hroderick-thr
10 - Fireball

Please mark solved if it did the trick.

Likes are nice.

Solves earn clout