Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Re: Alteryx Server Usage Monitoring & Reporting


Just upgraded to Alteryx Server 2018.4. also downloaded latest from download portal. I configured the tool correctly and I get a Tableau workbook with data, except for the last dashboard called 'Alteryx Server | Usage'. Looking at datasource behind the sheets in the viz, there are missing fields such a NewUsers, SerialNumber, ServerDataTime, StoppedUsers,tool_group, Count.


Looking at Alteryx_Server_Usage_Report.yxmc, the nested macro "RunBatch.yxmc" throws an error. Inside this macro the error seems to a batch file in the run command tool: 

Error: RunBatch (695): Tool #1: The external program ".\CollectionCheck.bat" returned an error code: 1
Error: RunBatch (695): Tool #29: The external program ".\CollectionCheck.bat" returned an error code: 1


I was able to run my own batch file correctly and I see collection outputs.


Can you recommend a fix?


Designer must be configured to send usage data to the server:


Does this resolve your issue?



Customer Support Engineer

Thanks for the response but no, this doesn't resolve it. I am running this directly on the server. I wouldn't have to add 'localhost' would I?


I am able to run mongo with params from command line and get output but not when using this macro/bat.




The error occurs because the "Enable Desktop Usage Report" checkbox is checked, but Designer has not sent usage data to the server to create the Collection the Usage Report uses.


Un-checking the check box or configuring a Designer to send usage data to the server should stop the error.

Customer Support Engineer

Hi Angela,


We don't have that checkbox checked. See screenshots. Error is in Collection Check tool container which contains only one tool - the runbatch macro. This macro is fed by multiple interface tools but not the check box for 'Enable Desktop Usage Report'. IMHO, it has to be one the actions in this macro since I did get it to work by 

hardcoding the command args in the top Run command tool (AlteryxGallery Query).




Does anyone have a solution to this?




You are correct that the "AlteryxServer | Usage" tab of the Tableau workbook is not populatedThat tab refers only to usage from the Designer and won't be populated unless you have done all of the below.


I wasn't able to view your screenshot of the macro configuration in the workflow itself.  That's what @AngelaO was referring to:


Enable Desktop Usage.png


Any time that box is checked, you'll see an error if you have not already made the modification for Desktop Usage Configuration.


Make certain that you've either unchecked the box on the main macro configuration OR that you've configured the RuntimeSettings.xml as described on the help page that is linked above.


Edit Runtime Settings.png

Configure for Desktop.png


If you have not amended the RuntimeSettings.xml, reopened Designer, and run a workflow from there, you won't have any data in the "AlteryxServer | Usage" tab of the Tableau workbook.



Please note that the errors you're observing in the RunBatch.yxmc are because you did not set the debug values within your submacro, so it's still using the default values rather than pulling the correct path from the RuntimeSettings.xml as it would if you'd run it from the full workflow.


Submacro Debug.png


Lisa LePome
Customer Support Engineer -- Knowledge Management Coach
Alteryx, Inc.
Alteryx Partner

I ran into the same error and this helped (I also had to check the box for "Advanced options" in the usage macro) and left the default database names in there. Thanks @LisaL



Picking this up again! ... and still can't get it to work...


I modified RuntimeSettings.xml and added PhoneHomeUrl like so



Quick question: is PhoneHomeUrl same as BaseAddress? see screenshot. 


I also checked box for 'Enable Desktop Usage Report' so I should be good to go. I ran the yxmd (w/o errors) and checked the output but last tab in Tableau workbook is still not populated.


Any other thoughts or ideas?





Ok after a lot of testing this worked.