community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Python tool could not create a job to manage a process

Highlighted

I'm having a similar issue to this one; however, I can't seem to get past the issue using @LarryR 's suggestion like the OP. I'm on my server box and ran python fine as my username. I then wanted to see how the server would process my python in the gallery so I closed alteryx and ran alteryx as another user (my service account that runs my gallery jobs). The python was operating normally but I had an issue with my Internet explorer setup when running selenium. I changed a few IE settings and decided to restart alteryx to make sure the changes stuck. I again ran as that same service account and now that user can't get the python tool to work at all. Note that my normal account where i just double click alteryx is still not having any problems. It's only when I'm running it as a different user. When I ran the task manager there were several orphaned instances of python, jupyter and jupyter-notebook. I deleted them all in an attempt to clear the error I'm receiving but no luck.  Also my gallery is still running my python jobs just fine using that service account. It's only when I run alteryx on that box as a different user with the service account that I get this error.

 

Any ideas on how to fix this issue?

Capture.PNG

Alteryx
Alteryx

This is 100% a permission/process issue.

 

 

Because the Job (This is a window process management structure thing) failed to create....you are seeing stray processes when you shutdown.

I will have to work with the server team to figure out what is going on here.

I'm not making any promises, but I did see your post.