community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

File Browse Tool - File Upload Error!

Meteor

Just looking into publishing an example workflow that uses the file browse tool.

 

I have managed to get this working on Designer and it does succesfully publish to server - however I'm greeted with an error:

 

"File Upload Errror

 

Requested file is either too large or the file format is unsupported:

 

 Capture.JPG

 

Which is unexpected as the file is .csv and under 1KB in size.

 

Any ideas on this would be much appreciated.

 

Meteor

This error is related to using the correct format for 'arbitrary file specification':

 

ie: CSV Files (*.csv)|*.csv|All Files (*.*)|*.*

Hi,

 

Is this issue resolved ?

Atom

Any solution for this problem (Gallery Requested file is either too large or the format is unsupported.) Please?

Meteoroid

Hi Nagesh, Not sure if this will work with you, but I found making sure the Arbitrary file specification was in the same syntax as 

 

CSV Files (*.csv)|*.csv|All Files (*.*)|*.*

 

did the job for me when having the same issue. You can extend it as needed, for example: 

 

CSV Files (*.csv)|*.csv|All Files (*.*)|*.*|Excel Files (*.xlsx)|*.xlsx

 

Cheers, Tim

Asteroid

@timrains  thanks for posting this.  Is there a reason you included *.xlsx and Excel(*.xlsx)?  

 

I am encountering the same problem with an app that I built.  The files I am loading are .xlsx format and they are small so I don't understand the size constraint message.  When the app is run in the gallery I get an error.  When I run the app from my desktop there is not problem.  The files were  generated using the render tool.  I wondered if that process "tweaked" the .xlsx format enough to trigger a problem in the gallery.  I am a little perplexed.  

Meteoroid
Hi @papalow I think that the inclusion of *.xlsx and Excel(*.xlsx) is actually just the one version (i.e.after the pipe is what is actually used, with "Excel" is what is seen in the interface). However, you may be right that your report format may cause issues - I've found some of the formatting slightly different. What is the error you get? A potential workaround might be to use a raw excel template for the report output, but I don't know your use case which may complicate matters.