Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Connecting to Google Drive Files in Alteryx Server

7 - Meteor

Hi All - trying to find a way to fix this. We are currently rolling-out our server instance. We use Google Drive extensively and we have a lot of workflows that point towards google drive. Our current solution has been to use Google File Stream and have everyone map shared drives to their "G:/" Drive.


However, when I tried the same on server it did not work. I have also tried to use UNC paths, but I guess the way that Google Drive is set-up there is no UNC path.


Wondering if anyone has solved for this issue. It would be great to allow Server to access Gdrive files the same way that users currently do where we could just add a service account shared to that folder/file.


Any and all ideas welcome!



7 - Meteor

I would add that we have gone down the path of using the Google Drive/Sheets connectors, but Infosec isn't very eager to continue that usage.

17 - Castor

@LanceFaceNo solutions here - but i'd add that I don't think Google Drive/Sheets would help much anyway. I assume you are on an SSO system and you'd need a service account (try telling that to InfoSec) for Server compatibility today.


If your Server is an EC2/Compute instance on AWS or GCP - that may sway InfoSec into allowing integration with a bucket system on the same platform (S3/Cloud Storage) since the connection would be internal and not externally exposed.

8 - Asteroid

@LanceFace have you considered giving permissions to those who are running the worklows that uses gdrive into the root folder which is basically the computer name of the machine where your gdrive is set up? In our case, we created an active directory group for all the users in our team. We then grant permission into the group to allow read/write access to that gdrive folder.

7 - Meteor

Thanks digitalmemo - everything led me to believe that it was not a permission issue (we could access through designer locally), but you were right! After adding the local administrator account as the "run as" user, it was able to "see" the G: Drive.


Thanks so much!