community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Tableau - Designer x64The Designer x64 reported: InboundNamedPipe GetOverlappedResult

Atom

I'm getting this error when trying to publish my flow in Tableau Server.

I'm getting my data from an Oracle OCI connection (SQL searches), and when I run the flow without the "Tableu Server" tool it goes fine, but when I try to publish it, it breaks with this error. The problem seems to be, as I've found through some tests I made, on the third connection to DB.

 

I've already tried several things I've found in other posts, such as being sure about the types of my variables (all my strings types are "V_WString", and I've also tryed as "V_String" and the error persists). My databases are not too big and I don't have a memory problem, I'm running it in a SSD.

 

In some other flows I made, I didn't have any problem in publishing in Tableau Server, but sometimes, such as in this case, this error appears.

I don't know what else I shoud try.

 

Obs: in the image, it's all in portuguese.

 

 

Highlighted
Alteryx Certified Partner

Hi @LidiaG 

 

This is a shot in the dark, but, if it's not already, change your Python config to "Production" vs. "Interactive".

 

Other than that... does the error come up whether you're creating a new data source or overwriting an existing?

 

Last suggestion I can think... you mentioned that you did try to switch WString fields to String, but a String field may still allow some characters that Tableau doesn't like. You can try using the below formula which will delete any character code that is NOT within the char code 32 - 126 (Hex 20 - 7E). You can use this in a Multi-Field Formula tool and apply it to all your Text fields or whichever you suspect might have some weird characters. 

REGEX_REPLACE([_CurrentField_], '[^\x20-\x7E]', '')

 

Hopefully one of these suggestions helps!

Jimmy
Teknion Data Solutions

Atom

@jrgo, it's worked! Thank you so much for the answer, I used the ReGex expression and now it runs.

 

Also, my Python was already in "Production" mode and the error was coming up both when I was creating or overwriting a data source. But apparently the problem was in fact wth some weird characters.

 

I'm really grateful for your help!

 

Lidia

Labels