Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

SMTP fails in Mail Tool after switching to version 2018.3.4.51585




I had workflows configured to send mails out using the mail tool in the version prior to 2018.3. This had the Autodetect SMTP. I was able to send emails out via the Workflow. After upgrading to 2018.3, I see the mail now requires you to specify the SMTP. I checked with my IT, and he gave me SMTP Server: Port 587.

mail config.png



I put these in these field, but now my flow runs into errors:

Email (88) Record#1: Unable to send email: "Error with FROM: 530 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM [] ¶"


Can you please advise what to do here? My previous workflows worked with no issues (version prior to 2018.3) where I didn't have to specify the SMTP field.






It may be that the Outlook server is now blocking this send and they need to add a mailbox for for it to work?


Not really. The same workflow in version 2018.1 runs fine with no problems. In that version, the mail tool had the Autodetect SMTP option which version 2018.3 has removed. I ran the mail tool with the following options checked in 2018.1 version


mail config old.png


In version 2018.3 after I upgraded, I had to specify the SMTP field:

mail config.png


Can we get the Autodetect SMTP option back in version 2018.3?

Community Operations Manager
Community Operations Manager



We have removed the Autodetect due to auto detecting SMTP can be a security concern. Your 2018.1 workflows should work if you do not change the SMTP setup you had in the Email tool in 2018.2. 


Please review the 2018.3 help documentation. If you continue to have issues please contact Support. 




Alteryx Certified Partner
Alteryx Certified Partner

Hi @DanM I've noticed that if you make any changes to the workflow (even if it's not against the email tool), it causes the tool almost to reset and does ask you to configure the SMTP.


It doesn't only arise if you make changes to the email tool.



@DanM, thanks for explaining the reason behind the change.


Question here on how to use SSL with the email tool in 2018.3 .


We can generate a successful SMTP connection under Advanced options > System settings > Gallery SMTP Configuration.  However, the email tool inside the workflow is fails in designer.  The same is true for an After run email event.


Does the email tool require an option for SSL?  I reviewed the email tool documentation but did not how to configure an email tool to use SSL. 


There is a check box to Use SSL in the Gallery SMTP Configuration.  Figured there might be something similar in the tool.  Or we may need to add a new email box as mentioned above. 


If I can provide any more details or context please let me know.  Likewise happy to bounce this over to support if community is not the right forum.  Thank you.



Community Operations Manager
Community Operations Manager



The Email Tool is a basic SMTP tool. It does not support any authentication at this time, so your SSL will not work. The server setup you are referring to does not relate to the Email tool. That setup is for the server sending email messages from the server to users which is not related to the Email Tool



@DanMthank you for the reply.  Sounds like rolling back to 2018.2 is the right solution at this time.  Appreciate you sharing the expertise. 

Community Operations Manager
Community Operations Manager

@jasonMedina, the only change that has been made to the Email tool is to not have autodetect in the tool. The Email tool in prior versions along with this version only support Windows Authentication, so if you had it working with another SSL prior to this version I am not aware of how you accomplished that.


Here is some further information -

@DanMthank you - rolling back to 2018.2 worked.  The workflows are running and email again!