We have extended our Early Bird Tickets for Inspire 2023! Discounted pricing goes until February 24th. Save your spot!

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer and Intelligence Suite.

Password Protected File pushed to Database - Error returned

IlliasB22
6 - Meteoroid

Hi, 

 

I have created a workflow to automatically pull in the the newest excel file from a shared drive and included the R tool to remove the password protection on it. However, when I use the Output Data tool to upload it to the database it throws the error:

 

"Error opening" "SELECT", '...column names...' FROM 'table name': No columns returned

 

The workflow is below - I have tried including a Dynamic Input tool between the R tool and Output data tool but this doesn't work as the Dynamic Input tool still sees the excel file as password protected

 

IlliasBoudellioua_0-1660121644147.png

Any help would be appreciated

3 REPLIES 3
IraWatt
17 - Castor

Hey @IlliasB22,

It sounds like it could be an error in the database query. Does it work if you just connect a text input tool to the data output tool? Could also try the Password Protected Excel Input Tool - Alteryx Community 

IlliasB22
6 - Meteoroid

Hi @IraWatt - thanks for the speedy reply

 

The suggested solution of text input tool -> data output tool doesn't work as the text input tool throws the below error:

IlliasB22_0-1660128686234.png

 

I assume this is because it is password protected?

 

Also, I have tried installing the suggested password protection tool but it doesn't get any further than this:

IlliasB22_1-1660128795978.png

 

Any guidance on the above mentioned?

 

Thanks

 

IraWatt
17 - Castor

@IlliasB22 I have had a look round and cant seem to find your error. I would suggest trying to write to the database using the in DB Tools using the data Stream in then Database Write tool:

IraWatt_2-1660129231601.png

when you click install then it should appear here in the in/out section of the tool bar:

IraWatt_0-1660128959484.png

 

Labels