Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Data Cleansing tool suddenly stopped working. Invalid Path: "Cleanse.yxmc"

5 - Atom

Hi all,


Hoping someone can help me out here as I have suddenly found that in all my workflows I am receiving errors as the Data Cleansing Tool has suddenly stopped working with the error message Data Cleansing "Invalid Path: Cleanse.yxmc".


Even if I create a brand new workflow with just an input tool and data cleansing I still get the error.


I have even uninstalled and reinstalled Alteryx and it still comes up with the error ! :(


Alteryx Invalid Path error.PNG


How can I see what Path is being used for a tool ?


Any help is greatly appreciated.



Alteryx Alumni (Retired)

That is definitely odd, as if the file was missing, then normally the icon would not even show up. The Path for that Macro is


<Alteryx Install Folder>\bin\RuntimeData\Macros\Cleanse.yxmc

Has there been any change in versions or Alteryx Install Location recently?


Try putting the attached Macro (Back up anything before overwriting) into that folder and see if that corrects anything. Otherwise, reach out to




5 - Atom

Hi Kane, many thanks for responding. I replaced the macro but no joy so I have emailed Alteryx Support.


I will post the answer and fix if I get one back into this thread. 



5 - Atom

For anyone that experiences this I thought I would close off the loop as were able to find a fix.


The fix they suggested which worked was as follows:


Hi Matthew,

We have seen this when there are possibly duplicate versions that were installed or something was corrupted with the tool. Could you try uninstalling one more time, and then removing (after backing up by making a copy) the following folders and their contents:


Then, you should be clear to reinstall.



I now have the Data Cleansing tool back :) Phew.....

9 - Comet

+1 this worked for me. 


I was getting errors on Data Cleansing and other standard-tool macros.  I have Alteryx installed on an AWS Workspace as my primary set up, but I have a copy locally as well.  This messed up my Workspace install for like 3 days before I found this thread.  Luckily I had a back up but it was so frustrating the past couple of days, thank you so much for posting the solution!

5 - Atom

thank you!!! 

13 - Pulsar
13 - Pulsar

If anyone else comes across this issue. Then this solution listed here by @MichaelAd worked for me and is much quicker that re-installing:


1. Close Designer

2. Rename the AddOnData folder in %ProgramData%\Alteryx\DataProducts

3. Restart Designer (to recreate the AddOnData folder)


I think could be due to installing some of the Starter Kits, which is the only change I made for my Alteryx supplied macros to become corrupted. It might be worth others validating if this could have been the reason for them too?


Joe Lipski
13 - Pulsar
13 - Pulsar

I've narrowed it down to the specific file that caused me the issue...


It's a corrupt Qlik Tools file from the Qlik Analytics Samples, so I think you should just be able to delete this to fix the issue.




I'll email my findings to

Joe Lipski

This did the trick for me. Thank you, Joe!

12 - Quasar

consider voting for which says to have Alteryx fix the ki8ts so they do not cause these issues