Get Inspire insights from former attendees in our AMA discussion thread on Inspire Buzz. ACEs and other community members are on call all week to answer!

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Publish to Tableau Server Tool - Error when tds file is attached

6 - Meteoroid


I was trying to use the new Publish to Tableau Server tool and it worked pretty well without attaching the tds file.

I'm wondering if anyone can explain this error message? Do I have something wrong with the workflow or the tool or the Tableau Server settings?

Thank you!

8 - Asteroid

I am using Tableau Server & Desktop 2019.4.3, recently upgraded from 2019.2.  I am using Alteryx Server & Designer 2019.2.  I've not had to change the Tableau version info in the tds file since I started publishing from Alteryx to Tableau.  Make sure you're also replacing any special characters with underscores.  I had hyphens in mine and had to change to underscores in the tds file.


I'm happy to jump on a call with anyone to help debug any issues.  

7 - Meteor
8 - Asteroid

Maybe.  In version 2019.4, there were a couple of bugs introduced involving publishing data to Tableau.


  1. Fixed Decimal values are published as string rather than fixed decimals.  This was fixed with version 2020.1.  The only way I know to fix this is to either upgrade to 2020.1 or downgrade to 2019.2.  I'm not sure if 2019.3 works or not.  We skipped that version.
  2. Publishing Hyper with TDS files fails.  This is still failing in any version 2019.4 and up.  A defect ticket has been created for their developers to resolve this issue.  (DE24553 - unable to publish .tds files in 2019.4+).  The only way I know to get Hyper+TDS working again is to downgrade to 2019.2.  A work around for this while keeping on 2019.4 or higher is to switch to publishing data as TDE rather than Hyper.  To do this, you'll need to recreate your TDS file from scratch using TDE data rather than Hyper data because Tableau will not allow you to simply swap out the underlying data in your TDS.  This can be time consuming depending on the complexity of your TDS file.

We're currently running Alteryx 2020.1 and Tableau 2019.4.  Any data we're publishing to Tableau with a TDS file, we are doing so as TDE.  Any data we're publishing to Tableau without TDS, we're doing so as Hyper because it is faster.  Either way, I recommend not staying on 2019.4 because of the first issue I mentioned where fixed decimals get published as strings.  I'm pretty sure you can get around this by changing to float or double but my business stakeholders are pretty set on not having variable length decimal values.  So, this wasn't an option for me.


Hope this helps.  If it doesn't, I'm happy to jump on a call with you.

8 - Asteroid

I have the same error. I trying it with Alteryx 2019.4 and also with Alteryx 2020.1. Tableau Server is on 2020.2

I always get this error message when trying to publish with a hyper file:

Error: Publish to Tableau Server (2): Tool #227: Cannot access file: C:\Users\XYZ\AppData\Local\Temp\Engine_49256_0ce5247155864f088b6237e28ff28a9f_\History.tdsx

and this, when trying to publish a tde file

Error: Publish to Tableau Server (2): Tool #252: Tool #4: Tableau Server API Request (Publish file) Error Code 400011: Bad Request -- There was a problem publishing the file '10425:fce2bab074724757937c549f0b498d89-1:0'.

When I look in the temp folder I can see that no tdsx was actually written. And since the temp folder always changes with each run, I can also not just try to create tdsx with 7 zip myself to see if it works then.

7 - Meteor

I found out that my issue had to do with my time fields.  Tableau did not like them.  I turned them to string fields and it worked just fine.  


To find the issue, I clicked on the hyper file link in the Alteryx results pane.  That opened the file in Tableau which errored stating that the specific field is not recognized by Tableau.

11 - Bolide

I am getting this error, did you find a resolution for your error?