Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Control container: Internal Error - Anchor was not closed

5 - Atom

Hi All,


My workflow has several nested control containers within a parent control container. In particular situation, user need to disable some nested control containers. In 2023.1.1.123 version, this process works normal, however, if my workflow run in 2023.2.1.51 or above version. The workflow crashed and pop-up an error message: "Control container: Internal Error - Anchor was not closed." I found another post in Alteryx community that described same issue. And the solution is to remove nested control container or ensure all nested control container is enabled. However, this solution is not suitable for me, anyone have another solution? Many thanks.


Engine team has been fixed two issues related to the nested disabled Control Containers:

1. GENG-3404: Control container with nested disabled control container inside causes an error


2023.1.1 (Patch 6) March 7, 2024

2023.2.1 (Patch 3) March 14, 2024

2. GENG-3381: Macros that contain a control container and a nested macro with a relative path causes error

2023.1.1.336 (Patch 5) January 16, 2024

2023.2.1.89 (Patch 2) January 25, 2024

6 - Meteoroid

Does this mean the fix will come in March?  Is there a workaround in the meantime?


Correct, the fix will be available in March.

A possible workaround is to disable all Browse functionality by ticking “ Disable All Browse Tools” checkbox in the Runtime tab of the Workflow window.

7 - Meteor

Hi! I have Error: Dynamic Multi File Sheet Names (22): Internal Error - Anchor (22:Output7) was not closed


Could you please help me to fix that?

6 - Meteoroid

I don't have the ability to easily download and install the latest software update, so are there any other workarounds? I attempted disabling all browse tools, but I ended up receiving the same error. Its worth noting, I have no issues running the workflow in designer, but it returns "Internal Error - Anchor (154:Log) was not closed" when attempting to schedule on gallery.

8 - Asteroid

I am getting the same error on 2023.2.1.133. Have tried disabling and even deleting browse tools, no effect. Flow runs fine in Designer, but if I run as App it produces this error?


Has anyone got a solution.

5 - Atom

Hey all I am running into this in  Version: 2024.1.1.49 Patch: 1, I have control containers with disabled regular containers in them. 

6 - Meteoroid

Unfortunately, also having the issue with 2024. (Patch 2).


Could you please share a workflow example that represents this issue?