Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

CSV error too many fields in record #1... but different!

8 - Asteroid

So here's a weird one.  the "too many fields in record #1" error but there are not too many fields.  

One might think there's a hidden carriage return in one field (I've encountered that before) but see here for when I open csv the file in excel, save it, close it, and run the plan again there is no error!  I make no change and tadah!


Next time the error happens I'm going to try opening it and NOT save it to see if it still works.

edit: Nope doesn't help (of course) also opening and saving in Notepad++ doesn't have the same effect as saving it in excel (still as a csv) without any changes.


Setting it to "ignore errors" just corrupts my data so that's a nogo.


Any ideas?


Thanks all!

12 - Quasar

Have you tried setting the Delimiters to \0 and increasing the Field Length?  Then use the Text to Columns to split the Input.


CSV File.png


8 - Asteroid

I had to wait a day for the error to resurface but yes that kinda works.  How does one go about getting the column headers corrected then? All the columns are just numbered (or the entire list of label names deliminated by commas for each column. ufdah!) instead of properly named.

I guess I can go manually rename all 49 columns.. ><



12 - Quasar

Untick option 6 'First Row Contains Field Names' on the Input Box for the CSV File, to have your headers as Record 1, then add a Text to Columns, to split your data into your 49 columns.  Then after that, use the Dynamic Rename tool and take the headers from the first row of data...


Dynamic Rename.png