We're excited to announce that we'll be partnering with Credly starting October 19th - see what this means and read the announcement blog here!

Alteryx Analytics Hub

Find answers, ask questions, and share expertise about Alteryx Analytics Hub.
SOLVED

Error while running Analytic app from Alteryx Gallery

mhhusain
5 - Atom

Hi Team,

 

I am facing issues while running my analytic app only when ran from Alteryx Gallery and not when ran from Designer. This app basically takes input sheet name and output folder path from my input questions and then within the WF creates multiple sheets on the grouped column I want for. Its using Create Table and Render within the WF. 

 

My basic goal is to use the dynamic questions to assign values to my WF as to from where I need to read file and where I need to store them. 

 

I am attaching error from gallery and WF for further checks. One is where user passes the output folder path and other is where I am using %temp% to create output files. 

 

Happy to share more info if required. 

 

mhhusain_0-1620636589988.png

 

2 REPLIES 2
ENix
8 - Asteroid

May be worth masking the file path in the error log - looking at the filepath I can tell where you are having the issue as I have worked there previously!

 

Does the folder you are trying to output to already exist? In your Output version, use a Folder Browse tool instead so you can select a folder that definitely already exists. Alteryx cannot directly create directories (there are ways to this but would need to execute commands).

 

Also worth looking at which credentials have been saved when uploading the workflow to the gallery - if it has been uploaded using your credentials it won't work when a user then runs and tries to write to a location you do not have access to. You can choose to have the workflow run as the user executing the workflow or to enter credentials each time it is run.

mhhusain
5 - Atom

Thanks for coming back on this.

 

I found a solution to my problem somewhat inspired by the description of your solution. I was trying to run the WF using the gallery creds which was ran by a service account which of course didn't have access to my folder locations hence was failing each time. Now while saving the WF I am editing the WF Creds and asking WF to ask for user creds to run from gallery. And these set of users have access to my shared drives hence Alteryx executes and creates files successfully. 

Labels