community
cancel
Showing results for 
Search instead for 
Did you mean: 

Dev Space

Customize & extend the power of Alteryx. SDKs, APIs, custom tools, and more!

Publishing workflows with encrypted password to the Gallery

Meteor

I did get it to work by installing v.3.1 of the tool.  In my Designer (2019.2), I have to right-click in the Toolbar (toward the top of the screen, under the "Collections" buttons) and choose "show depreciated tools" so that the old version shows up, but then I can add the working depreciated tool to my workflow.

 

Please "star" the product idea I added to the Server Community:  

https://community.alteryx.com/t5/Alteryx-Server-Ideas/Salesforce-Connector-v-4-1-doesn-t-work-on-Ser...

 

Someone who knows told me that getting a lot of stars on a product idea is THE way to tell Alteryx how important something is.

Meteoroid

Can anyone point me in the direction of how to download previous versions of the connectors? I can't seem to find where I can download v3.1 anywhere.

Meteor

@BlytheE ,

I am trying the deprecated version of Salesforce connector. However, I can't find where I can provide a custom SOQL query. I can only find the query builder which doesn't give me everything I need such as relationships. Am I missing something?

Alteryx
Alteryx

Hi @dalym - try bringing the non-deprecated version (the one without the banner) onto the canvas, right-click on the tool, select Choose Tool Version, and then choose Salesforce Input 3.1. This option might not exist if you haven't installed the latest versions from the Gallery. But the way to know what version you're using is that v4 includes an 'Environment' dropdown and doesn't ask for the URL, whereas v3.1 (the one you want with the custom SOQL query) has a text box for URL. Once you connect in v3.1, there is a radio toggle at the top to switch to Custom Query. We updated the tool so that the versions basically stack on top of each other and you can switch between them with the right-click menu. v3.1 can be scheduled without issue. Let me know if you have any questions!

Meteor

I have tried to install v3.1 of the Salesforce Input Tool in 2019.2 and now I'm not seeing any Salesforce Input connectors - not even version 4.1 that was showing up before. I added the deprecated versions to the toolbar and I'm now seeing the deprecated version of the tool but when I right-click on the tool I don't see any way to select a version.

 

Is 3.1 compatible with 2019.2?

Meteor

Try type "salesforce" in the search bar, you will see the tool. 

Meteor

@zhuyyu I had tried that (great minds think alike!) and nothing came up...

Meteor

Hi , Just for your information, V3.1 does compatible with 2019.2, I'm using it now. The way I work around, copy the salesforce input tool from the workflow you built in the past. The good part for doing this, you don't need put in your password and token if they are still valid. 

Meteor

And I think you need install it one more time, I guess it somehow failed to import the tool. 

Meteor

Any magic to getting 3.1 to install? I've tried half a dozen times and nothing ever shows up in Designer. I also have 4.1 installed and that disappears when I run the 3.1 install. The only message I get from the install is the initial dialog saying an admin needs to install the tool for all users...

 

When I looking in my appdata/roaming/Alteryx/tools folder, there is a new SalesforceInput folder with no version number but nothing shows up in Designer