Welcome to the Gallery. Please feel free to post and comment, and check out our FAQ!

Community Gallery

Post, download, and share all of your favorite tools and workflows — from Alteryx supported to user-built.
Introducing Alteryx Marketplace

Easily access verified, supported, and secure Add-Ons.

8 - Asteroid

Having the same issue as @Emil_Martensson (null numeric values automatically converted to 0's instead of keeping them as null). Has there been any updates on this? Thanks!

8 - Asteroid

@JesusER @Emil_Martensson I think that error might be to do with the rules of the Tableau Hyper API - I don't think it allows you to store a value as 'null' if its numeric/bool. You'll have to use string unforunately and deal with it in Tableau. 

10 - Fireball

Is there a way for this tool to recognize who on Alteryx Gallery is running the workflow and use their credentials to authenticate and publish to Tableau Server? Just because the Alteryx developer had access to publish to Tableau doesn't mean the person who shared the Alteryx workflow would have the same access. 

5 - Atom

You can test the 1.2.0 Beta version.

8 - Asteroid

@elsastark I have this EXACT problem as well. Tool works fine locally, won't work on gallery. 


@barcris Where is this 1.2.0 beta version?!

5 - Atom


You can download from the following link, but you must log in with the alteryx user account, or if you wish I can send you a message, as it does not allow me to attach.



5 - Atom

Regarding this Tableau Output tool, I've tried the link above to the Tableau Help page, and it says Access Denied. Anyone else getting this? I'd like to understand some of the configuration options, for example, the Data Source Metainfo TDS file - what are some use cases of why this option would be used and how you use it. Thank you.

7 - Meteor



We created a "universal" credential set and publish most workflows using those (rather than individual user credentials).  At the time of publication, you have to select that set of credentials rather than what you might be using in the local workflow.  This allows analytical apps to run regardless of who signs in and also keeps scheduled workflows from breaking as individuals come and go.  We did the same with the Tableau tokens.

5 - Atom

Having an issue with v1.2. The output tool creates a temp folder, but looks like it tries to make the same folder twice, resulting in a "FileExistsError" which stops the flow.

8 - Asteroid

I'm having an issue with this tool where persistent crashing occurs if I try use it inside a tool container. Enabling the container after it being disable will hang alteryx. Trying to move it out of the container will cause the same thing. 


This tool is very handy, I just wish it wasn't so error prone. 



5 - Atom

We are trying to use this new supported tool instead of the old version; however, we are having numerous issues.
- The Tableau Hyper data sources posted on the server are only of type String.

- Pulling dates from a SharePoint list and posting them to the Tableau server convert the type to string and add 70 years.


Is anyone else seeing these issues?

8 - Asteroid

Anyone else getting NaN when trying to upload Null (Doubles) to tableau?

5 - Atom

I am having an issue when connecting to the tableau outout 1.2v. it says Error: Tableau Output (680): All incoming anchors closed, but plugin has errors.



8 - Asteroid

this tool has a hive mind. if there more than one it will give amibguous plugin has errors thing when another tool has errors. Also it changes dates to the future. It wont accept INT of any kind has to be fixed decimal if there are nulls in the columns. and wont accept datetime and only accepts date. I tried both 1.2.0 and 1.3.0 im on Version: 2022.1.1.42604. 

5 - Atom

and the upsert and update function doesn't really work , if anyone know how to make it work?

8 - Asteroid

I am receiving an error when trying to publish to Tabelau Server...and like many Alteryx errors....I have no idea what it means or what to fix.

Error:  "Got an invalid value nan for column "Contact", it must be an int instance"

In addition.....I closed workflow and Alteryx....and now I can't open the workflow without crashing Alteryx. 

I'll put in a ticket with support. 

UPDATE (03.30.2023) I upgraded to the new version of Alteryx (2022.3.1.450) and was able to get the tool to work. HOWEVER....I cannot connect to Alteryx Server or Gallery with the update. Alteryx is aware of this issue and yet the bug persists. So I'm left with the option of having the upgrade to run the workflows with the new PAT tool and then trying to schedule/monitor my workflows directly on server by logging directly into the server. I haven't even tested to see if the workflow will work on server....because I've been too busy installing and uninstalling Alteryx Designer to figure out how to get this thing to work. Alteryx is supposed to make data easier by not needing coding skills. However, I apparently need to be a PhD level IT/IS person to get the program to work properly and figure out what the errors mean.
5 - Atom

Has anyone experienced this error where it won't create or update the extracts because it already exists? - I checked the folder and there's nothing in there. When I delete the temp folder in the error message it creates another temp folder and repeats the error.
My DCM settings are set to allow all like other users have mentioned which has allowed me to connect. I can see the projects and the existing data sources within those projects but can't make any changes or add to the projects.




My Error Message: Error: Tableau Output (2): <class 'FileExistsError'>: [WinError 183] Cannot create a file when that file already exists: 'C:\\Users\\XXXXX~1.DEA\\AppData\\Local\\Temp\\tmps_04m_xt\\'



8 - Asteroid

Has anyone discovered what the size limit is with the new tool? I've had as large as 4 million records and as small as 11,000 records fail when writing to Tableau Cloud. I saw another post that said the file size couldn't be more than 500MB?

500MB Limit 

I'm trying to figure out how much I need to aggregate my data vs. dashboard functionality in Tableau. My clients are going to be so very happy that I can't automate daily data updates any longer. 😢

5 - Atom

I'm trying to change the target project name via a control command in a macro. In the initial setup of the Tableau Output tool I select the "Default" project. Then try and change that with the value from the Control Command. The updated value isn't applying. Has anyone tried this before and gotten it to work?

8 - Asteroid

any update on the Null turning in to 0's? that is an a unacceptable bug.

7 - Meteor



Did you find a resolution to the error "All incoming anchors closed, but plugin has errors." ? I'm getting this error quite frequently on various flows i run! 

7 - Meteor



Did you get any resolution to your error above re: local hyper files?  We are experiencing some errors in our flows that have a very similar error to you.  The error for us is:


[WinError 2] The system cannot find the file specified (then a file path to a local hyper file)


It is accompanied by an "All incoming anchors closed, but plugin has errors" error also.

5 - Atom

@AdeHowe we did not resolve the tool. We instead used the runcommand tool and use tabcmd to publish straight to Tableau Cloud.

8 - Asteroid

@Hunter12 .... we found that you need a data cleaning tool right before you write the file out to ensure that there are no null values in numeric fields. This will mean that you will need to do an extra calculation in Tableau if you do not want zeroes instead of NULL in the numeric columns. 

Also, setting up the data source in the DCM and linking the credentials also seems to help performance.

And don't forget that dates must be converted to string before writing the file to Tableau Server....and then you get to have an extra step in Tableau converting them back to date/datetime.


Hope this helps!

5 - Atom

I am getting an error on all of my tableau output tools now. 


Here is the data on the 'Processed' column. I have tried using int16, 32 and 64.



Does anyone know how to fix this?


8 - Asteroid

Still having issues with these workflows running on server and updating data sources that are published on Tableau Server. Sometimes the overwrite works and other times it does not. However, I am seeing results that indicate that the workflow ran successfully on server.

I have numerous workflows that run early in the AM and update daily reporting for my clients. If the data is not updated because the Tableau Output tool isn't doing it's job, the client will lose confidence in what we are doing for them.



8 - Asteroid

@MikeMarandola I'm seeing that you have NULL values in that column. Unfortunately, you'll need to change those to 0 using the data clean tool...and then change them back somehow in Tableau.

Or maybe make it a string field with, 1, 0 and "NULL". Then create a calculated field that can be a number field with 1, 0, and (null).

It is not ideal that we can't keep our nulls and empties as null and empty with this tool.

5 - Atom

Having an issue with v 1.1.1 trying to load up about 8 GB to Tableau. Just runs forever without never really starting the Tableau Output tool (at least per the log).

Not sure how I load this to the server anymore, any ideas? or am I cursed to change everything I have to an extract model on Tableau.


8 - Asteroid

Please help!


I'm trying to use the Tableau Input Tool. I've been able to connect and can see the data source. But every time I put in a table name and run I get this error:




I've put in every possible thing I can think of that would be the table name. There's only one table in the datasource so I've tried the table1 that was recommended by the help page.

I'm not sure what else to do. Has anyone else had this problem?

8 - Asteroid

I've received a new error message from the Tableau output tool: 

An incoming anchors closed, but plugin has errors.


I searched for the error and found it associated with Python SDK tools. I believe the Tableau Output tool is using Python to run the TabCmd API in the background. But I'm not entirely sure if that is the issue here. 


UPDATE: Apparently I have a missing field. As Taylor Swift would say, "It's me. I. I'm the problem. It's me."😁

7 - Meteor


We are trying to use v1.1.1 on the server as we are not up to speed on DCM.


After some Failed to sign into Tableau errors I am using a Personal Access Token.


Which works on my PC's Designer, but not on the server. 


Logging into the Worker with my Admin account, I tried to run on Designer there, but access was denied (different user? but token saved?)


Now I setup the workflow to use my credentials and I get a whole new error: AlteryxService_RetrieveSecureData failed 


Any help would be appreciated

5 - Atom

This tool defaults all null numeric values to NaN which is not needed. We need NULL numeric values as NULL. not NaN. All of our dashboards broke down because of this. Do you have any solution to tackle this?

7 - Meteor

Has anyone been able to pair the Tableau Output with the DCM Connection Interface tool on the Gallery? We have a workflow that a few different folks will run, but it only works with the person who published it. Anyone else who tries to run it gets the error message "Failed to signin to Tableau."


Tried with Ver. 1.2 and 1.3 of the Tableau Tools 

SDK Access Mode is set to AllowAll on the desktops and gallery

Confirmed that the other users have all set up their Tableau DCM connections correctly. 

Confirmed that the other users have the same Tableau Server permissions as the publisher. 

If the users all "hard code" their own DCM creds in a separate workflow they all work, so this leads me to believe that the Action tool shown below is either not actually updating the Connection ID or there is something else that also needs to be replaced for each individual user. 



TS DCM.jpg



6 - Meteoroid

When using Tableau Output v1.3.1 and attempting to use a credential from DCM using the "Setup Connection" button, I get the error "This Credential was created using a schema that's not currently present on your system" error.  I have tried creating the credential on Alteryx Gallery and in Alteryx Designer then syncing.  Both methods throw an error.


Has anybody else had this error?  Most important, how do you fix this?


Tableau Output v1.3.1

Alteryx Designer v2022.3.508

Alteryx Server v2022.3.508


Step 1 - Create credential in Alteryx Designer

configure credential in alteryx designer.png

Step 2 - Sync credential with Alteryx Server/Gallery DCM

sync credential to alteryx gallery.png

Step 3 - Select synced credential in Tableau Output v1.3.1 to "Setup Connection"

select test2 credential after sync to alteryx gallery.png

Step 4 - Get error which flashes so quickly, that I had to take a video of it and go frame by frame to see the error (and grab this screenshot).

error when credential created in alteryx designer.png

Step 5 - After the error flashes, the credential information is displayed, but no connection made

credential information displayed after selected in error flashes for a split second.png

7 - Meteor

Hey everyone, @AlteryxProducts 


I just updated from 2022.1 to 2023.1.1.200 to be precise and can't connect the Tableau Output Tool to my credentials anymore using the DCM.

When I try to it just goes blank in the configuration windows and shows this error:

Tableau Output Tool.PNG


Any ideas whats going on?

Was working (mostly) on older version but since we updated internally the Alteryx Server I also had to update Desktop Designer version.


(Obviously there is still another issue with the Tool where if fails to append data properly when releasing on the Tableau Server, but that issue now is totally new and makes it impossible to use at all.)

5 - Atom

Having issues with numerical fields


Double, fixed decimal and int are all resulting in the tool failing to append (set to overwrite).


Float sometimes works, but that results in records entering 'nan' rather than nulls, where a null entry is important info.


I have some workflows where they never fail to append with similar records using fixed decimal, does anyone know why it rejects fixed decimal? Is there something I should be doing to the records to ensure they upload properly?

5 - Atom

I'm trying to connect to an already published data source and it says the table name doesn't exist. I'm using the table name that is in Tableau. The tool can tell me that the table doesn't exist when I enter the name but give me no choice of options. How am I suppose to specify the table name?

8 - Asteroid

Is anyone else experiencing a bunch of issues using DCM with the Tableau Output tool?

Got one user who authenticates to the tool, enters in their DCM credentials, and then the configuration pane briefly shows the tool settings before just blanking out.

Got another user who goes to set up the DCM connection but the 'Select Technology' drop down doesn't populate with 'Tableau Output' so they can't move on.

8 - Asteroid

@JeffJeffrey12 are you still experiencing this issue? I'm seeing the exact same thing.

7 - Meteor

I'm trying the Tableau Input tool and getting the error "Specified table does not exist". I tend to think of the data source as the table. Is there a default table name or some way to identify what the table is called?

7 - Meteor

@JonathanAllenby There was some issue with the Access Tokens losing their names when updating to new version and syncing.

I had to fix all Access Tokens again for it to work.

8 - Asteroid

Potential bug with Alteryx Designer 2022.1 and Tableau Output v1.3.1 (and possibly earlier versions):


  • Tableau Output tool does not support spatial data.
    • "We are not supporting spatial data at this time. All incoming anchors closed, but plugin has errors".
  • We've confirmed that this issue occurs on even the latest patch of 2022.1: 2022.1.1.42673
  • We've confirmed that this issue does not occur on 2022.3 or 2023.1
Screenshot 2023-09-18 151839.png


6 - Meteoroid

Hello Community,

I had many issues with trying to get the tableau input and output tools working and I was able to get this achieved. Here is what I found out, in case it helps:

The issue is that the Tableau tools cannot pull in data that was created in tableau. For instance, if tableau queries snowflake, you will not be able to pull that query result data into Alteryx via the tableau input tool. If you try you will get the table does not exist error. 

The solution is to query the data from say snowflake directly via the data input tool or In-database tools( I used the data input tool). then use the tableau output tool to push the workflow results to tableau. Now any data that you push to tableau via the tableau output tool will be retrievable via the tableau input tool. 

to make this all work you must configure the tableau output tool as follows:
1) first make sure to set up DCM following this guide: How to: Set up DCM for Designer and Server (alteryx.com)
2) then create a connection to your database of choice, by entering and saving your connection credentials.
3) in the tableau output tool on the data tab click on the Select project option you want, then lower down the select data source you want.  the first time you do this select "New Data Source". this is where your data will be pushed to
4) in the Options tab Name your data in the Data Source name field, then Select the Output Option as create the first time you publish the data, and change it to Overwrite for updates to that data in Tableau. Make sure to leave Data Source Metainfo blank, and don't select Encrypt at Rest or local path. In table Mapping in the table name for incoming Connection #1 enter "#1:table1". Finally, leave the Spatial tab options all blank.

For the tabluea input tool you must configure it as follows:

1) in the Connect to area select your saved tableau connection
2) in the Data tab Select your Project(Tableau folder), then Select Data Source, that you created and pushed to Tableau with the tableau output tool with the above steps. 
In the options tab enter "table1" in the Anchor #1 Table Mapping field.

That's it. Good luck and hope this helps others