Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Where is Alteryx Service? Not in services list.

Alteryx Partner

Hi -

I have previously been able to set up the controller and run schedules.  We have designer / desktop with scheduler.

This stopped working a couple days ago.  On that day we installed the Salesforce Kit and also some Windows updates.


When I tried to view the schedules, I saw the following (grey part) and when then selecting the controller I had saved, received the error message on top.



Since then, I've reviewed all the controller settings, deleted it from the scheduler and tried to re-add (I keep getting the above).

Some other threads in the community suggested finding the Alteryx Service and confirming it is running, that nothing else is on port 80, etc.


I do not see ANY service called "Alteryx [anything]" in my services list.  I assume there was previously and that there needs to be for scheduler on desktop?


Does anyone have any suggestions?



Alteryx Certified Partner

Yes, the Alteryx Service should appear in your services list for the controller and worker. Make sure your Alteryx System settings are configured correctly as "Controller" or "Worker". 


from Services/msconfig:


























Community Operations Manager
Community Operations Manager

Have you installed a new version of Alteryx recently? Can you confirm that you are running an admin version of Alteryx. You must have an admin version in order to see the Service.


Another possibility is that for some reason your service was uninstalled for some reason. You can install the service using the command line cd Program Files\Alteryx\bin\alteryxservices.exe \? and use the install function posted.


You also have the option of reinstalling alteryx as well.


If these issues are not resolved by attempting one of these troubleshooting steps, please reach out to our Support team.





Alteryx Partner

I think the no-Admin may be the issue.

When I installed the Salesforce Kit, it was a "no-admin" version.  I'm going to do a reinstall and report back.

Alteryx Partner

Hi Charlie -

Thanks for getting back to me!

It had worked previously as "Designer and Scheduler only".  Is that not the proper selection for a single desktop running designer with scheduling option?


- Pete

Alteryx Partner

Thanks Dan.

For designer + scheduling, you do NOT set up just as worker or just as controller.


The issue was the install of one of the starter kits for "no admin" removing the service from the machine.

I reinstalled designer from scratch, the service reappeared, and we're all set.




Alteryx Partner

For those trying to use the Command Line, here are some additional instructions:

  1. Run your CMD as an administrator
  2. first command is: cd c:\Program Files\Alteryx\bin\
  3. then: alteryxservice ?
  4. then: alteryxservice start

It will tell you if you have a licensing issue...

Alteryx Partner

Also, if that helps, make sure you have only the Alteryx Desktop Automation license active, and deactivate others which might still be active, such as Alteryx Designer...

Then get into Options/Advanced Options/System Settings and go through the steps:Capture.PNG





How do I determine if I have an admin version of Alteryx installed or not?



Connie Sawyer

Hey @csawyer,


It will say on the about screen under help


Alteryx Version.png