Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Google Drive Input Tool Alteryx Server error 'NoneType' object has no attribute 'Get'

8 - Asteroid

Hi all,


We've been trying to update some of our workflows from the deprecated google sheet input tools to the newer google drive input tools. However, we've been struggling to get them to work on our alteryx server.


Some info:

Alteryx Server 2022.1.1.25127 (config: DCM optional, SDK allowall)

Alteryx Designer 2022.1.1.30961 (config: SDK allowall)


Google Custom API App setup according to the documentation:

Client and ID, token name are stored in DCM and the connection through DCM is selected with AMP engine on.

When connecting on Alteryx Designer is does go to a authentication window in the browser to allow input, after which you can see all files and select the ones we want.

When uploading to the alteryx server, no errors or warnings appear, but when we try to run it on the alteryx server it throws the error '''NoneType' object has no attribute 'Get' "

Any idea if this is expected (i.e. it doesn't work on Alteryx server) or if we have setup something wrong.


Do let me know if you require and more information, thanks in advance!




14 - Magnetar

Hi @robbinrv, please take a look at this KB article: 

This might be related to the tokens for the connection are not available or configured properly on the Server. 

8 - Asteroid

Thanks @gabrielvilella Solution B was part of the issue indeed!


After this, we still experienced problems with setting up the googleapp following the documentation:

It continued to throw the same error.


When setting up the app, we also had to provide an email address for a test user, which resolved the problem in the end.

14 - Magnetar

I am not sure at this point what is wrong. You might need to contact support. 

8 - Asteroid

All good @gabrielvilella we managed to resolve the problem by adding the test user email when setting up the API credentials on google. This and the synching of DCM credentials solved the problem. Thanks again

8 - Asteroid

can you please document/elaborate the steps for us lesser minions? Thank you very much

8 - Asteroid

Apologies for the delay in the reply, I need to sort out my notification centre as I missed this.

The steps below are the ones that worked for us in the end.


1. follow the steps as outlined in Alteryxs' article: At some stage it asks if you want to add a TEST USER account > add your email again there too.

2. Enable AMP on your desktop in the user settings, DCM, and allowall SDK access modes in your user settings. (on 2022.1 this was required for us, now that we are on 2022.3 'Allow' works too)

3. Install the googledrive tools if you haven't already.

4. Drag in the google drive input tool > setup new connection using DCM

5. Add datasource > google drive input > Name it

6. Connect credentials > Create new> Custom App

7. Create New credentials > name it and add the client Id and secret from the google api step 1

8. add an oauth session token > name it

9. test your workflow on desktop

10. Sync your DCM connection and credentials with the server by clicking on File > Manage Connections > Synchronise > wait till it's synchronised.

11. upload and test the workflow