community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

Alteryx Older version Compatibility

Highlighted
Alteryx Certified Partner

I am trying to publish a workflow build in 2019.1 designer  to 2018.4 server. But it does not retain any of the macros. and I had to build the whole workflow again. Why Alteryx does not provide the compatibility with recent versions.

Alteryx Certified Partner

The support of previous versions isn't perfect, but it usually doesn't produce these results. I suspect the problem you're experiencing has to do with moving from Designer to Server, rather than 2018.4 to 2019.1. 

 

What macros are lost? Are they macros made by Alteryx, or custom ones you have made? Are those macros saved on your user toolbar? Are the macros saved at a locations that the Alteryx service user/server can access? 

Alteryx Certified Partner

These macros are build by me and not the alteryx macros. I zipped the workflows adding all the tools but when i open it on server (2018.4), nothing works fine. Every tool lose the setting i made and macros shows the question mark.

Alteryx Partner
Alteryx Partner

Hi @Bharti ,

 

You can adjust the html of the workflow itself depending on the tools you are using but you will need to start with the macros you built first and save them as 2018.4.  Then you will need to do the same for the unpackaged workflow.  The issue you will run into is you will still need to package the workflow in 2018.4 and the only way to do this is in Alteryx.  You can do this if you installed an admin version of Alteryx on your PC initially by doing a second install of Alteryx as a non-admin version in 2018.4 which would allow you to have both versions your pc. 

 

Disclaimers: sometimes by having multiple versions installed you can create other issues with the registery.  Major versions tend to have more differentials especially as they update the tools themselves to HTML 5 interfaces which may require you to rebuild the workflow.