community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

2019.1 Server & Designer Upgrade

Highlighted
Asteroid

Hello All,

 

We recently upgraded Alteryx Designer and Server from 11.5 to 2019.1. Upgrades seemed to have worked fine. We first upgraded Server, while keeping Designer version to 11.5. We were able to publish all our workflows from 11.5 Designer to 2019.1 Server and all of our functional test cases passed. We then upgraded Designer to 2019.1 for a few test users successfully and the standalone version seems to work fine (apart from documented know issues).

 

We are able to add Gallery to our local Designer successfully (though it sometimes asks us for username and password, which should not happen as we have enabled IWA). We are also able to download the workflows that are already published in the gallery. However, when we try to publish new workflows, or save existing ones, we get errors - different errors each time (attached). 'API Not Enabled', etc. Our Designer is active with valid license provided by Alteryx.

 

Has anybody faced this issue, if yes, were you able to resolve it? 2019.1 Gallery Error.PNGSaving Workflwos to Gallery - Gallery not populated by default2019.1 Gallery Error 2.PNGError while saving workflowsGallery - Opening Workflows.PNGOpening workflows from Gallery

Moderator
Moderator

Hi @AnupD,

 

Thank you for posting.

 

Have you tried to removed the license and re-add it again please?

 

Kind regards,

 

Paul Noirel

Customer Support Engineer, Alteryx

Asteroid

Thanks for your response. We requested new trial license keys for the server. We received and installed them yesterday. We are able to publish and run workflows successfully in the Gallery but the behavior is a bit different.

 

The Designer is not able to pick up the Gallery automatically while publishing. Eg: We see 'Welcome, Placeholder' instead of the Gallery name, workflow name does not populate automatically, Location field does not show me my Private Studio name, instead it shows 'Gallery Location'. Also, I'm not able to version-control the workflow, in other words, if I try to save an already saved workflow, it prompts me a screen shown in screenshot below.

 


image.png

Moderator
Moderator

Hi @AnupD,

 

Thank you for the update.

 

I would suggest to contact Alteryx Customer Support (support@alteryx.com) for further verification.

 

Regards,

 

Paul Noirel

Sr Customer Support Engineer, Alteryx

Hi,

 

We are planning for an upgrade from 11.7 to 2019.1 version. Are there any server upgrade guide? Can we do in place upgrade or do we need to do fresh install? 

 

Thank you,

Hari

Community Operations Manager
Community Operations Manager

@HariReddy 

 

Here are upgrade resource

https://community.alteryx.com/t5/Alteryx-Server-Knowledge-Base/Install-or-Upgrade-Alteryx-Server/ta-...

 

If you have any questions or issues please reach out to Support.

 

DanM

Asteroid

@PaulN  We have engaged Alteryx support. I'll update you on the outcome. Thanks.

Asteroid

This has been resolved. After working with the support team for hours and trying to figure out discrepancies by reviewing the logs, it turned out that Proxy Credentials were enabled on my Designer and my windows password had changed recently. So the Designer was trying to pick my old password as I did not update it in User Settings. Disabling the Proxy Credentials resolved this issue.

 

Recommendation for Alteryx: Enable SSO wherever possible - Proxy Credentials, Publish to Tableau Server, etc.

 

Thanks.