Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Software Install / pre-requisites


Had older version (11.8?) from a nano-degree I was doing, that was causing issues so I attempted to uninstall.  Normal control panel uninstall would not work,  Eventually, I think it was all uninstalled manually.  Weeks later (today), I have full blown license key, attempting to load 2018.4.  The pre-requisites screen comes up mentioning previous Version uninstall...  I select next like many posts say to do but the software load stops there with more errors...  "source installation package for the product ALteryrxProductName is out of sync with the client package.  Try the installation again using a valid copy of the installation package AlteryxInstallx54.msi"...  followed by "unable to uninstall older version of Alteryx Designer 2018.4 (User).  Please uninstall it yourself in control panel"   I have never had 2018.4 and that is what I am attempting to install.  I tried to install a few older versions and got the same messages.




Usually, when remnants of Alteryx are left on the machine after uninstalling, the answer to this is to delete the folders below:






And, also to remove Alteryx-related registry keys.


This should only be necessary if you have already attempted uninstalling via the Alteryx installer, and the control panel.


In this case, Support worked with @rs6833 and the solution that worked was installing the Admin version of Designer.


I would recommend trying this before going through what Dave outlined;


Make sure you are installing an Admin version of Atleryx and when you execute the installer you are right-clicking and selecting "Run as Administrator". This should clear the issues out.




Admin version install worked perfectly.  Now if I can retain admin rights on my company laptop, I will be good.  Thanks!