community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

R tool Fake Errors

Hello all,

 

I have a workflow that uses four R tools and fails after exiting each R tool. The errors I receive are as follows:

 

The R.exe exit code (4294967295) indicted an error. Yet, I receive the correct output, which is why I called this Topic "R tool Fake Errors"

 

So I have no problem when it comes to manually running this workflow. However, when it comes to scheduling this workflow, I face the following challenge:

I have a second workflow that is dependent on this workflow running successfully. I am currently using Adam Riley's runner macros to schedule dependencies. However, those runner macros have an error constraint of 0. In other words, the dependent workflow will only run if the initial workflow completes with 0 errors. I created a duplicate runner macro that bypasses this 1 error and indicates that the workflow has completed successfully even after it runs through this one error. This seems to have worked for scheduler and the dependent workflow. (For now)

 

However, the question I have for the Alteryx Community:

 

Is this a typical error that any of you have encountered before? I've read some threads where someone suggested to re-run the workflow and that should solve the issue, which sometimes does solve the issue, but how does that work when you are scheduling this workflow in question...? 

 

Any suggestions are appreciated. 

 

Julie Hwayek

Pulsar
Pulsar

It is indeed a fake error.  See this link for more info:
https://community.alteryx.com/t5/Advanced-Analytics/Boosted-Model-Error/td-p/5509

 

Thank you for your response mbarone. I already modified the Runner macro Adam Riley created to encompass this 1 error and pass the workflow as succeeded, but I wanted to know if there's a real fix to this rather than my workaround. Hopefully, they will implement your idea in this other post you sent me, that would be ideal.

 

Thank you,

Julie 

Atom

Hi Julie,

 

I hope you've found a solution to this error already, but I solved it by adding "browser()" at the end of my script. This results in a warning but no error. :)

 

-Matt

Alteryx Partner

Hello Team

 

Stuck also with this error "R.exe exit code (4294967295) indicated an error".

My macro works perfectly when I launched it individually but crashes when I insert it in an iterative job

 

Very annoying

 

Hope that Alteryx technical team will fix that in the next release

 

Best Regards

 

Arno

 

Alteryx version : 10.6.8.17850

 

 

 

Alteryx
Alteryx

Hi @arnaud_langlois

 

From the following community link did you try the suggestions by @rlangestr?

 

https://community.alteryx.com/t5/Advanced-Analytics/Boosted-Model-Error/td-p/5509

 

Ending the R-code with gc() 

 

Please let me know if that resolves your issue?

Christian Rincon
Manager, Customer Support
Alteryx, Inc.
Pulsar
Pulsar

For me, it's hit or miss if the garbage clean up function resolves this error.  Some scripts it does, some it does not.  Would be nice to have Alteryx suppress this error all together.

Alteryx
Alteryx

 

@arnaud_langlois has confirmed via email that Ending the R-code with gc() has resolved his issue.

Christian Rincon
Manager, Customer Support
Alteryx, Inc.
Alteryx Partner

I totally agree...

Meteor

Hi Christian - I'm an analyst and not a programmer.  How would I "go into the R Code and end with "GC()"?

 

Thanks!

Meghan

 

Labels