Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Poly-Split Error

Highlighted
Alteryx
Alteryx

I have a workflow that is splitting polylines at a point.  The workflow uses the Poly-Split tool to break the polylines up, then it organizes them into their new groups and rebuilds them with the Poly-Build tool.

 

The problem that I am having is that the poly split tool orders the split sequence geographically, not ordinally according to the polyline.  This means that when I rebuild the polylines the points are out of order no matter what I do, which gives unusable results. How do I get the Poly-Split tool to keep from breaking the workflow before it even starts (I'm hoping it's just an error in usage)?  I have attached a sample workflow below that just breaks and builds the polylines without any processing in between, and the error exists there.

Regards,
Stephen Ruhl
Customer Support Engineer

Alteryx Certified Partner
Alteryx Certified Partner

Okay, interesting question. I've not come across them before but your data isn't actually just a set of lines. In the Browse the SpatialOb is called a PolyPolyLine. Each line is actually made up of a series of lines.

 

Alteryx doesn't deal with these well in the Polysplit and Polybuild tool, giving the results you've seen. Instead we need to split into regions, keeping an ID to rebuild on, then split into lines and then rebuild using the combined grouping of regions and objects to build them, and combine back on Object.

 

I've attached a workflow, hope it makes sense.

Highlighted
Alteryx
Alteryx

This is great, thanks!  I'll incorporate it into my workflow today.

Regards,
Stephen Ruhl
Customer Support Engineer

Labels