Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Macro Field Summary file input

Inactive User
Not applicable

Hello, guys! By these days, I've been studying how to make best use of the macro customization behind Field Summary tool. However, unfortunately I don't have its file input: ".\Sample Data.yxdb". I'd like to analyse properly the results of each built-in interaction when the macro was been writing.

Could someone share this file in here please? Thanks a lot!

Alteryx Certified Partner
Alteryx Certified Partner

Hi @Inactive User 


If you click on Options > Advanced Options > Workflow Dependencies when you throw the Field Summary tool in a workflow, you can see where it is.


In general, it's located at this path in a regular installation:

C:\Program Files\Alteryx\bin\RuntimeData\Macros\Predictive Tools\Sample Data.yxdb



Inactive User
Not applicable

Thanks for answering! Sadly I've just checked the suggested location and other directories and the "Sample Data.yxdb" is not there...I think there is no other way except asking directly for this file. I appreciate your help! :)


Alteryx Certified Partner
Alteryx Certified Partner

@Inactive User 


You're right. There's no such file.


Maybe this file doesn't even exist on purpose - I see there's a Select tool with "Unknown" option checked.

Or it was just used once to generate metadata for the Select Tool and the developers pulled it out - The Select Tool is also updated by a List Box Interface Tool.




Inactive User
Not applicable

Thanks man! :)



Im facing this issue for long time unable to solve it :


When i attached the Field Summary in the workflow then attached the interactive link to a browser an error appears  stating :


An error occurred while rendering:
File Path in htmldependency must be rooted in Alteryx install Folder:"C:\Windows\assets\combined.min.js"


I have tried many thing but no luck such as :
1- going through in alteryx >options>Advance options>Workflow dependency>Clicked test>clicked in the red error tried>it says Directory does not exist>apparently  directory is selecting \\Mac\Home\Users\MAS\AppData\Local\Alteryx\bin\RuntimeData\Macros\Predictive Tools\Sample Data.yxdb


Sample Data is not there at all so i have changed Twice to assets\combined.min.js & assets  folder
Mac\Home\Users\MAS\AppData\Local\Alteryx\bin\RuntimeData\Macros\Predictive Tools\assets\combined.min.js.yxdb


Still makes the same error.


I do not know why it is going to that folder 
2- reinstall alteryx 3 times no luck again
3- ensure that in user setting (Macro it is properly linked with alteryx folder )