community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
#SANTALYTICS

Gather all 9 clues to complete the final Weekly Challenge on Dec 16!

Learn More
SOLVED

Error message

Meteoroid

Hi, is there anyone know how to deal with the error "the field schema for the output changed between iterations”? I have a macro to run through the entire file, every sheet is in the same format but somehow one sheet come up with this error message. Thanks.

Alteryx
Alteryx

Check for a new field, a field name change, or a field data type changing.  Without seeing the workflow, it's difficult to tell where that change could have occurred.

Regards,
Stephen Ruhl
Customer Support Engineer

Alteryx Certified Partner

@Pasty

 

Every sheet may look the same, but (especially with Excel) it's very easy to overlook that the schema of one of the sheets changed. It could be that a field name was altered unknowingly or that the import driver is classifying a field as a number when it was a text in the others. Whatever the case is, something is changing. If you don't want to go through the trouble if identifying that, you can adjust your properties of your macro (Interface Designer (CTRL+ALT+D)) and tell it to output the data by their name, essentially how a UNION tool works, which ignores schema variations.

 

image.png 

 

Hope this helps!

 

Best,

 

Jimmy

Highlighted

Be sure to inspect if the Auto Field tool is involved as well.

 

I ran into this error when running a Batch Macro. My field names all matched, but an Auto Field was at the end of my Macro, thus constraining the types/length of data that were attempting to Union and throwing the error.

It worked for me for the first time. and the macro ran successfully without errors. again on the next day, same error is coming. 

Labels