Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Check out our powerful new search update! You can read more here. Please let us know if you have any feedback by creating a topic here.

Download Tool Error Since Upgrade to 2018.1 - HTTP/1/1 405 Method Not Allowed

Highlighted
Asteroid

I recently upgraded from 11.0 to 2018.1 and after the upgrade, a workflow that included a Download Tool that had previously worked with 11.0 failed under 2018.1 with the following error:

 

HTTP/1.1 405 Method Not Allowed
Content-Encoding: gzip
Cache-Control: private, no-cache, no-store, must-revalidate
Content-Type: text/html; charset=UTF-8
Date: Mon, 28 May 2018 14:57:32 GMT
Edge-Control: no-store, bypass-cache
Expires: Thu, 01 Jan...

 

My workflow takes a user provided url and tries to download the HTML from the page.   If downloaded successfully, it then goes about parsing the data.  Unfortunately, since the upgrade it no longer downloads the data. 

 

Has anyone run into this problem. 

 

I've attached the workflow

Highlighted
Alteryx Certified Partner
Alteryx Certified Partner

I have both versions of Alteyrx installed on my machine and it does not appear to work in 11.7 either.

 

I don't have Alteryx 11.0 so I cannot test on this.

 

Can you be certain that this still works on 11.0 and nothing changed on the end of the site? Are you able to access an environment with this verison still installed?

 

Ben

Asteroid

Hi Ben,

 

Thanks for your input on this.  Unfortunately, I had to uninstall 11 when I installed 2018.1.  I believe I was running 11.5 and I can confirm the script worked without any problems.  That said, it's still possible that something changed on the site, though when I reviewed the html in google developer yesterday it was not apparent. 

 

Jim

Labels