Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

python tool jupyter notebook loading error

8 - Asteroid

using version 2021.6


all of a sudden python tool stopped working, it returns there is no valid meta data and the attached screenshot. No latest change in the workflow or Alteryx designer, could anyone help please?





Error: Python (21): Traceback (most recent call last):
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\", line 194, in _run_module_as_main
return _run_code(code, main_globals, None,
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\", line 87, in _run_code
exec(code, run_globals)
File "C:\Program Files\Alteryx\bin\Miniconda3\envs\DesignerBaseTools_venv\Scripts\jupyter-nbconvert.EXE\", line 4, in <module>
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\site-packages\nbconvert\", line 4, in <module>
from .exporters import *
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\site-packages\nbconvert\exporters\", line 1, in <module>
from .base import (export, get_exporter,
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\site-packages\nbconvert\exporters\", line 13, in <module>
from nbformat import NotebookNode
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\site-packages\nbformat\", line 33, in <module>
from .validator import validate, ValidationError
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\site-packages\nbformat\", line 12, in <module>
from jsonschema import ValidationError
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\site-packages\jsonschema\", line 33, in <module>
__version__ = get_distribution(__name__).version
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\site-packages\pkg_resources\", line 480, in get_distribution
dist = get_provider(dist)
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\site-packages\pkg_resources\", line 356, in get_provider
return working_set.find(moduleOrReq) or require(str(moduleOrReq))[0]
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\site-packages\pkg_resources\", line 899, in require
needed = self.resolve(parse_requirements(requirements))
File "c:\program files\alteryx\bin\miniconda3\envs\designerbasetools_venv\lib\site-packages\pkg_resources\", line 785, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'jsonschema' distribution was not found and is required by the application




14 - Magnetar
14 - Magnetar

Try adding a Test Input tool in front of the Python tool.  Create a dummy column with a value in one row and connect to the Python tool.  It just discards the data from the Text Input and should clear the error in my experience.

8 - Asteroid

After trying endless troubleshooting steps, including reaching out to Alteryx support team, none of the troubleshooting worked. None to spot the issue.


Due to server admin version being 2021.1.6, we tried not to upgrade the designer version, however to me, the only option worked was to upgrade just Designer version to 2021.1.7. Luckily so far no issues.

8 - Asteroid

Thanks for your comment, it didnt work either for me.