Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Salesforce Input Tool - Existing reports error

6 - Meteoroid

When running the flow, trying to connect to a Salesforce report, I get the following error message.

Anyone that knows how to fix this?


Error: Salesforce Input (1): Traceback (most recent call last):
File "", line 160, in pi_push_all_records
File "C:\Users\b34434\AppData\Roaming\Alteryx\Engine\../Tools\SalesforceInput_v4.1.0\engine\", line 13, in process_report execute_report_run(self=self)

File "C:\Users\b34434\AppData\Roaming\Alteryx\Engine\../Tools\SalesforceInput_v4.1.0\engine\", line 26,
in execute_report_run pull_report_data(self=self, report_results_id=report_results_id)
File "C:\Users\b34434\AppData\Roaming\Alteryx\Engine\../Tools\SalesforceInput_v4.1.0\engine\", line 38, in pull_report_data with sf_proxy.manual_proxy_context_for_url(self.session, report_endpoint): NameError: name 'report_endpoint' is not defined

13 - Pulsar



In version 4.1 the python code has been changed to work with proxy. As I put the 2 codes above version 4.0 without proxy and 4.1 with proxy. I already advised to install both versions and select the desired one at the time of execution.


In version 4.0 this error does not occur



5 - Atom

I'm getting the same error in 4.0 


and the download page says:


Salesforce Input Tool Install v4.1 - compatible with Alteryx version 2019.2 and up

Salesforce Input Tool Install v4.0 - compatible with Alteryx version 2018.3 - 2019.1


indicating you should not have them both installed. 


All that said, I am more interested in HOW this is done.  What is the query to pull an existing report?

13 - Pulsar




I have both installed smoothly in version 2019.2 and 2019.3. To extract reports the salesforce input version 4.1 tool is bugged I advised him to install 4.0. I work this way on the designer.


I do not know why it has not tested in version 4.0 I passed it to him how to switch from one version to another and still didn't respond.



7 - Meteor

So even if we have 2019.3 or more recent you suggest we should download v4.0? How do we uninstall 4.1? Just deleting it in the Tools folder?

Alteryx Alumni (Retired)



There is a defect created for this issue (DE20556). There is a workaround that can be provided if you reach out to Alteryx Support. Thanks!



Jake Samuels

Principal Support Engineer
Alteryx, Inc.
5 - Atom

Had this same issue with 4.1, and below is the fix that worked for me:



5 - Atom

Thank you! That did the trick for me!



8 - Asteroid

@JakeS@SabrinaCB  Any update on when this issue will be fixed and a new version released?


Is there any page where we can follow the status of known issues i.e. DE20556?

5 - Atom

Thank you!!!!