Welcome to the Gallery. Please feel free to post and comment, and check out our FAQ!

Community Gallery

Post, download, and share all of your favorite tools and workflows — from Alteryx supported to user-built.
Introducing Alteryx Marketplace

Easily access verified, supported, and secure Add-Ons.


Hi, Latest one only supports with AMP on. Is this temporal situation or the tool will support only AMP mode from this version?

5 - Atom

Hi all;

Wondering if someone can help with some clarity on the authentication piece - as I'm struggling to get this through our IT group (large organization).  Looking at the detailed help on https://help.alteryx.com/20221/designer/microsoft-sharepoint it appears that we need to create an Azure app registration. 


My IT group is telling me that to get the client ID & secret we need to create a Service Principal - however my understanding of a Service Principal is that this is analogous to a service account - i.e. each user that needs to connect to Sharepoint should (per best practice) have their own Service Principal so that Sharepoint activity is traceable to a specific user. 


We are NOT using a server version; and are NOT planning on running workflows unattended - wondering what specific steps are required to authenticate with individual userIDs; not the Service Principal? 


Simplistically, I assumed that a login via browser would create a token (via Oauth 2.0) that could be used for a period of time to authenticate with Sharepoint sites that the individual userID has access to - I'm unclear the role of the App Registration in this - and as such not able to explain what is specifically required and why this is appropriate to my IT group.  It is not clear which mailbox the "App requests" that are generated through the sign in via browser end up - maybe we just do not have the right IT Azure folks in the discussion - but this has become a significant challenge.


Any help/guidance would be very much appreciated.

9 - Comet

G'Day gsmith28,


I think I mentioned our experience with this here previously; you seem to know more about the way Sharepoint authenticates than I do. Nevertheless, we have struggled a lot with this also. After upgrade things work fine - desktop as well as the server, including the DCM; (Prereq: Sharepoint Tool on both systems, ver. 2.2.0 Input/Output will be installed; Now Non-Admin Designer ver. 2022.1.1.30961 & Server 2022.1.1.40869); The advice is to remove the old S'Point connectors afterwards.

Sharepoint Admin needs to enable Alteryx to access the site (...You will then see the Tenant ID in the ...Site Contens/Site Settings/Site app permissions option);


Setting up a new connection on the Designer (Non-DCM);

1) I can confirm using the Browser authentication worked for with the Designer only; The Authentication Method will default to 'Built-In App';

2) The other option using the Designer only & the Tenant, Secret & Client ID's to be provided in the connection setup, also works. The Authentication Method will default to 'Custom App';

These above S'Point connections in a workflow can be shared with other users (however they will have to edit & recreate the connection);

The other option is to use DCM, which requires a Gallery server but it can then be shared with anyone as is (on the server or downloaded to a local machine);

5 - Atom


can anyone help me with this error ? 

SharePoint Output (32) The node "Properties" is missing the child node "SdkSettings"


Thank you 



7 - Meteor

I get a straightforward - "Missing Incoming Connection" error even though I am able to list and select the folder and file I want it to out put.


My Alteryx version is 2021.3.7




5 - Atom



Any alternative to connect to sharepoint 2019 list ? I do not understand how the tool support on-premises older version like 2013, 2016 but not 2019. 

7 - Meteor



Please can somebody help.  I'm using the Sharepoint output tool to write to an excel file (set to overwrite existing sheet).  This was working initially but now I'm getting the errors 'All incoming anchors closed, but plugin has errors' and 'All incoming anchors initialized, but plugin has errors'.  I only installed the plugin yesterday so it's the latest version. It was working one minute and then stopped without any changes to configuration.  I've restarted Alteryx to no avail.

I'm quite new to Alteryx so apologies if I'm missing something obvious.

11 - Bolide

Are there any plans for updating this with support for .xlsb?

5 - Atom

Hello Alteryx Team,

I was trying to import data from a SharePoint File via SharePoint Input connector but when I am choosing the Authentication Method as Sign in via Internet Browser, the Popup page appears to be blank and not letting me to connect. 

Is there any other way to connect to a SharePoint file? Will it let me connect if I choose to put Client ID & Tenant ID? Please suggest the same.




Deepak Saroop

8 - Asteroid

Can this sharepoint connector be added to a non-admin version of Alteryx?

11 - Bolide

I'm not in love with 2.2.0.


Please revert back to the 2.1.0 interface.


8 - Asteroid

I found this on another thread and wanted to make sure it was here.  For the current version of the tool Sharepoint Tool v2.2.0 (September 9, 2022) it looks like Nulls in Excel are being brought in as "nan" to the data set. Consider this a request to fix this bug.  Thanks, -Hayes

5 - Atom

Is there a way to upload a rendered excel file from the reporting suite using this tool?  I'd like to keep the visuals in those files

5 - Atom

Hello - I am trying to install the SharePoint Tool on my computer but when I click install nothing happens. It doesn't give me an option to run as an admin. Can someone please advise? 



5 - Atom

Hello, Could You please suggest the compatible Sharepoint Files Tool for Alteryx Server 2021.2.3?


11 - Bolide

Hi @Marian_Capita,


Personally, I like v 2.0.1 as I seem to have less hang-ups when I'm using the AMP engine if I am dumping my workflow output to Azure.



11 - Bolide

Hi @mcummins ...hopefully you got this resolved, but the best way is to close your designer, right click on the icon and  run as admin.  You may need your IT team to do this.  Once done, then open the SharePoint connector file that you downloaded from here.

11 - Bolide

Working perfectly!!

5 - Atom

The 2.3.0 version of the tools requires a different set of credentials to connect to SharePoint lists (as opposed to version 2.2.0), which is also different from the set of credentials needed to connect to Sharepoint files. These are thumbprint and private key.


Has anyone worked out where to take these from? 


Personally, it is also annoying that I need to know 5 random long strings to connect to Sharepoint lists and files: private key, thumbprint, client ID, tenant ID and client secret.



8 - Asteroid

A bit strange to have it Amp-only, as most API's require Amp be off if you are behind a proxy. Thus, we cannot use this tool in a workflow that uses APIs.

11 - Bolide

I like to use v2.0.1.


It makes my designer stable when using Azure input & outputs as well as tableau publishers.


I've found that using latter version of this tool tends to make designer unstable, and thus need to go to task manager and shut it down then open it up using the recovered workflow.

5 - Atom

Does the current release of for SharePoint Online work with GCC High environments?

7 - Meteor

Hello! I have never been able to get any version of these connectors to work for Files. I am able to connect to Lists.

I have tried several versions and several support tickets. Since we are upgrading to Designer 2022.3 I am trying SharePoint 2.4 version with Alteryx 22.3 and still no luck.


There are no Site Options when connecting for Files and not URL box like with Lists. When I run a Drive ID error occurs


If anyone has had trouble connecting with the SharePoint connector and can offer some guidance, I would appreciate it




5 - Atom

Hi All, 

I am using SharePoint Input v2.4.0, connecting to a SharePoint List View and am able to retrieve data in to Alteryx. 
However in my list i know i have a User Column that contains a array (Name, Email, Phone Number) 

I am only getting the display name in Alteryx, how can i access the other bits of information within the field eg email?


Thank you all.

5 - Atom

Hi there, looking to get some help with this issue I am facing with the SP output tool:



While the tool works well when run manually, it fails to authenticate when I run the scheduler. Currently running the latest version of Alteryx & the SP output tool and am using the Service Principal Authentication method (Client ID, Tenant ID and Client Secret). Can someone advise on how to work around this error? 

11 - Bolide

Hi @ykanabar ,


You probably wrote your workflow on your laptop designer, ran it manually, then went to schedule it and saw this error.


The reason is that Alteryx removes the Client Secret as it uploads the workflow to your gallery.  




Once you have loaded the workflow to your server, you need to open the workflow using the designer that is loaded on your server and enter the client secret on the respective output tools, then save it.  


It's a pain, and I wish that future versions of the software do not do this.


Depending on how you have configured your setup, you may need to get your server admin to help on this.


good luck.



7 - Meteor



We use DCM for our sharepoint client/secret and becuase you can sync that to your server, you can schedule these without having to have access to the server.  Check out their DCM documentation if you have not already to set that up.

5 - Atom

Hi All, 


I'm facing an issue when trying to write data to a SharePoint List using the SharePoint Output tool (V2.4.0). I'm able to connect to the SharePoint Site without errors but get the following error in the screenshot below which doesn't allow me to run the workflow. My Alteryx version is 2022.1.1.42590, I have the AMP engine enabled, and I'm logged in as an Admin for additional context. I've also included a screenshot below of the exact error. Thanks for your help!



5 - Atom

Hi folks,


I'm trying to use this SharePoint Output tool (v 2.4.0) to overwrite an existing SharePoint List. I'm able to connect to the Site & List just fine and it will even successfully write some (~600/1400) of the records before erroring out after about 2min: "Error in adding list items". It also oddly only writes one of my 12 columns.


Can anyone think of what could be causing this? Are there special characters or something that might be giving it trouble? I've tried skipping what might be problematic records around where it breaks, but it just breaks elsewhere.


Alteryx version 2022.1.1.42604, for what it's worth.



5 - Atom

Question from someone who has 30 mins with the tool...


Set this up and using Oauth/Okta to get to sharepoint files for access instead of using a linked folder through the organizational link on the OneDrive share.  When using the link on the OneDrive share, behind the scenes Alteryx puts in the path to a local file copy so when someone else accesses the workflow they have to change all the filepaths or point back to the share ... which points back to local synced copy.  So my questions:


  1. Is there a configuration to bring over data typing from Alteryx Databases or Excel files?  I didn't try Excel, but everything from an Alteryx database came over as a string.
  2. On the string, the typing came over as a VERY large string.  I can do cleanup to right-size these fields, but was curious about why they aren't better sized as part of the tool.


Many thanks for this tool and any shared understandings to follow.


- Brett

6 - Meteoroid

Hi @VojtechT. Is there an update on below where there is an option to download files only and not change the format when appending data?



5 - Atom

Thanks @JayMarie and @VojtechT!  This helps me understand current state a bit better.  If I am reading the comment correctly, it looks like the path to improvement is through file download?  Looks like the one option in current state is to download the file and it provides the local path as the result.  So if I add on an input node with macro input for the file path, it should read the file in "as normal" including all typing in the file?  Is that correct?


Is there file differencing in the download option?  E.G. Does the file download each time regardless of whether it was changed since last download or not?  Again goals are:


  1. Ease of use in an environment where there is shared access/authorship of workflow files and their supporting data (but not identically mapped drives of fileshares).  Having as few steps as possible to just run a workflow authored by someone else with data sources that both have security on.
  2. Performance.  Solutions that connect to data with speed comparable to local fileshares (or synced local copies from the OneDrive environment).




6 - Meteoroid

Hi @dorkbean . Just to clarify my question. I used the SharePoint Input and Output tools and use the Append option of Output tool so that it will just add my data from Input tool to my output data. My output data has a format already like colors and borders. When I run my workflow, all the formats are gone to all excel tabs but it appended the data to the specific tab I assigned. Do we have an option where it will retain the format and just append the data from Input file?

7 - Meteor


Has anyone been able to use the SharePoint connector that has a Multi GEO setup.

After extensive sessions with my SharePoint admin, we determined that our Multi GEO Setup uses a different search in the Microsoft Graph and is probably what is causing the tool not to connected to any Sites when using Files (Lists works for us, but that is because we input the site URL)


I am trying to see if we can pass a different Site URL through the Action tool - but so far it's not working.

8 - Asteroid


I just ran into the same problem.
We have a Multi-Geo setup as well. As i understand it, it means everything is on one tenant, but will have different urls depending on were data is stored.


Main URL:        company0.sharepoint.com

Region 1 URL: company0eur.sharepoint.com


The sharepoint connector will only show what is on the main url. 

We could really use a solution for this.

Currently considering workarounds, like using powerautomate to move the file from the region1 url to the main url whenever the file is changed so that the connector can reach it. but this would be a short-term workaround.


7 - Meteor


I have been trying to update the XML using the interface tools (text box and Action) to send over the URL; like the Lists has. But so far no lock,


Alteryx support said they sent it over to the dev team and they are working on a beta - but who knows when that will be,

10 - Fireball

Can we put DCM back as optional? 

DCM is not as stable and forcing us to use it has caused our Organization to be unable to use it past 2.1.0

5 - Atom

The latest version, 2.4.2 wipes out the ability to create a DCM connection. When you try to create one with this version of the tool, the dropdown list for type of connection is blank on an input tool.

5 - Atom

This article is excellent but out of date as there is new version February 2024:
These are the links I found useful


Microsoft SharePoint (alteryx.com)  revision history, bug fixes
Sharepoint Tools | Alteryx Marketplace - home page for tools
Install Custom Tools (alteryx.com) - Installing custom tools