Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Reading / Writing to Network Folders with Alteryx Server

13 - Pulsar
13 - Pulsar

My colleagues and I have been working with Alteryx Server for a while now today we were finally successful in inputting and outputting files to a shared network folder from Alteryx Server. Documentation for this solution may exist but I was not able to find it. Hopefully this post will save others some of the headaches we have had while trying to get this to work.


For context, our company has a pretty strict IT department, so part of the problem was figuring out if it was a permissions issue on our end or if it was a configuration within Alteryx Server. The answer was a little of both. Below is a list of all the items we tried before finally succeeding. The final step we discovered today is highlighted in bold in case that is all you care about.


Previous steps:

When trying to save a workflow to our Gallery, we would consistently get this error (K:\ is our main share network folder):

Exact same error as above!Exact same error as above! 


Attempted Solution #1:

One of the first recommendations we received was to check the box under "Workflow Options" > "Manage Workflow Assets" (highlighted in yellow in the screenshot below) when saving your workflow to the Gallery.



While this successfully got rid of the original error message, it was not the solution we were looking for. When checking this box, your files are packaged with your workflow and saved to new folder called "external" (see file path in screenshot below) within Alteryx Server. My understanding is this creates a static copy of your original file and breaks the link to your original file. If your input file changes, these changes will not automatically update in your workflow that is now saved in the Gallery.



You can find more information about the "external" folder here: Avoid getting "\external\1" when Publishing an Application to the Gallery  


This option may be the solution in many situations, but it was not the right solution for our problem.



Attempted Solution #2:

The next step we took was to update the "Run As" configuration in the Alteryx Server based on this post:

Solved: workflow cannot connect to Network drive  


After working with our IT department, we successfully updated this configuration:



After completing this step, we were optimistic that we had solved the issue but unfortunately we still had a few more issues to address.


Attempted Solution #3:

After further discussion with our IT Department, we figured out that the user that was set up to run our workflows in the Gallery was not given permission to access any folders. This was a good lesson in giving very clear instructions when working with a group that does not use Alteryx regularly. After getting all the required approvals, the "Run As" user was given access to the necessary folders.


Surely this will solve our issue...



Attempted Solution #4:

So we tried all the previous steps and finally had the permissions issues sorted out. And guess what, I still saw this exact same error message:



Ready to give up, we put in another ticket with Alteryx Support. We tried several solutions with several Alteryx Support Representatives, who were all great to work with, one of them made the following suggestion:


Solution: Update the file path to the UNC Path


Apparently, UNC stands for Universal Naming Convention and is something I was not aware of before today. Most of the items in this post are outside of my areas of expertise so I wouldn't be surprised if some of my explanations are not entirely correct or if this solution is something that is obvious to others. But if I can save just one person the time and energy we spent getting to this solution, this post will be totally worth it 🙂


To update the file path, go to "Options" > "Advanced Options" > "Workflow Dependencies". Select "All UNC" at the bottom of that menu.








Obviously, your path will say something other than "\\servername\path" but this was the final step for us. After making this change, the simple task of saving a file has never been so satisfying!





Update: About 5 minutes after finishing this post, I somehow stumbled upon this post that I somehow had not seen before:

Solved: Write from Alteryx Gallery Server to Shared folder  


Thank you for taking the time to write this up, I am glad you were able to arrive at a working solution  

I am curious as to why you changed the 'Run as' user of the worker rather than enforcing credentials to run the workflow at Server run time? 
You could also add credentials on server to allow users that have been given access to the credentials to run the workflow with different credentials (this can be found under Server Admin console)






5 - Atom

Made a user account specifically to say ... THANK YOU!! Informative, helpful post and it resolved my issue! Appreciate it!

6 - Meteoroid

Having a very similar issue, when you change those dependencies in the Advanced Settings, do you still select all the options under "Manage Assets" when saving to the gallery? 

5 - Atom

Million Thanks to this Post!! Logged in to my user account after long time just to say Thankyou for saving my time and energy 🤗