Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Not seeing new users

8 - Asteroid

Hi all,


I've recently added a few new users to my company's gallery but I am unable to find them as users, I had to search for their private studios to locate them and move to a desired studio, see example below:


I added the user Lucy and searching for it returned no results


 i was able to find her private studio and then move her to the studio I want. Currently this is the only way I can find these users I added (about 14 of them)



Clicking on the user name on the studio brings me to the Edit User page, so the user exists. I was also able to login as the user, download workflows, etc.. but I still can't search for the user.

UnseenUser3.PNGThis is an issue because I have to add the user to a data connection, but since I can't search for them, I can't add them, Anyone experienced this before?


Currently using Alteryx Server v11.3



11 - Bolide

Correct me if i'm wrong- but I think if you have "enable users to register" they have to register after you have added them for them to show up.

8 - Asteroid

Hi @Derangedvisions


Can't say i'm a server expert, but I believe the button only enables/disables manual user registration (i.e. a user goes to the server page and chooses to register). It doesn't seem to affect a user, after the admin has added him/her. From the docs:


"By default, users are not allowed to sign up for access to your company's private Gallery. To allow users to sign-up for your company's private Gallery, on the Users page, select Yes for Enable User Registration."


I also tried changing that option to "No" and add a new user, but I am still unable to see them.


Thank you,


11 - Bolide

@Carlos_A - interesting - I actually just added someone to our server, and i'm seeing the same thing you are (she isn't even showing up under users)


Could be a bug- this is the first time I've added someone since we upgraded to 2018.2. I'll have to look into this further!


Let me know if you figure it out!

8 - Asteroid

@Derangedvisionsinteresting that is happening to other users as well as in newer versions, we are still using version 11.3 of the server.

I have contacted Alteryx support and sent some logs to them, i'll post here again if I hear anything back.

11 - Bolide

I have also contacted support! i'll be interested to see if it's the same issue (even with us using different versions) 

Alteryx Alumni (Retired)

Hi @Derangedvisions,


I was on a call with @Carlos_A earlier today and we fixed his issue. We had to rebuild the search index of Alteryx Gallery (Lucene). This operation is generally done in coordination with Customer Support. As I understand that you have already logged a ticket with our team, my colleagues will be able to assist you.


Kind regards,


Paul Noirel

Sr Customer Support Engineer, Alteryx





11 - Bolide

Thanks @PaulN unfortunately we tried that and it didn't work- so they are still looking into it.  


Hi @PaulN


We tried clearing locks and re-indexing today with @Derangedvisions and this time it resolved the issue. We verified and the missing user is now showing up. 


Eddie Wong
Customer Support Engineer
5 - Atom

We are also seeing this is our test 2018.3 environment. Can somebody please post the steps required to resolve it?