Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Issue scheduling my workflow on Alteryx server and getting an error


actually okay. This tool, what is it? Tool #2


It's a macro of some sort. What is tool 10 within that Macro?

How can I find which tool within the Macro is labeled as #10 please?


sorry you right click on the tool and say show macro (or something to that effect) and while in that workflow search (Ctrl+F) for 10

Thank you. I did and only found two tools, there is no tool#10. I have done same on both my local Alteryx designer and also Alteryx designer on the Alteryx server.
The error is complaining that Alteryx server is not able to access tableau server. Is there any documentation or steps to follow to successfully schedule a workflow to refresh my .tde file initially published from Designer to tableau server. Were you able to do this process with no issues?
Also I have checked and able to ping the tableau server ip from Alteryx server as well.
  1. first make sure you have "Show all Macro Messages" checked in the run time tab for the canvas.
  2. You can do a find tool search to find the tool of interest.
    1. You may need to go into a macro to find it.....Macros in the messaging can be identified in the message prefixing
  3. Somewhere in this flow or macros you have a tool interfacing with Tableau, probably a "publish to Tableau server" tool.  Even if you are publishing there is back and forth signaling and thus you can have this error.  
    1. IN the config of the "publish to Tableau server" tool did you change the credentials to the server's service account credentials?  it may be just a simple oversight of not changing the credentials.  If you confirm the credentials in the tool config are correct for the server then can you or an admin sign into the server and run it manually under the server credentials to verify the issue?

Thank you, I was able to check "Show all Macro Messages".


I am not sure how can I access the config of the "publish to Tableau server" tool and check the credentials. Can you please guide 


you have to have the configuration view active and click on the tool


Thanks, that's what I do whenever I try to publish the .tde or .hyper file to tableau server. I put all those details with my credentials.

I am able to publish the file to tableau server with no issues at all.


I am also able to publish the workflow to Alteryx server. The issue I am facing is when trying to run the workflow from Alteryx server as well as trying to schedule it based on a frequency, we get the below error:


"Tool #2: TableauServer.Login (36): Tool #10: Error transferring data: Failure when receiving data from the peer"


I am not sure what it is required for Alteryx server to refresh the .tde or .hyper filespreviously published to tableau server through the Alteryx designer.


From the error it seems like it's a log in issue. I have also tried granting  Alteryx run as user admin access in tableau server and that didn't help.

I feel like another piece is still missing here just between tableau server & alteryx server.


Were you able to successfully have your .tde or . hyper files refreshed from alteryx server while they are in tableau server?

We update table server data regularly from Alteryx a server. Try having someone sign into Alteryx Server and run it to see if there is more info revealed

I have tried publishing to tableau server from the Alteryx designer located in Alteryx server and go the same error:


Error: Publish to Tableau Server (2): TableauServer.Login (36): Tool #10: Error transferring data: Failure when receiving data from the peer