We’ve extended Inspire Early Bird Pricing until March 1. Register now and enjoy 20% off conference passes and 10% off training passes. P.S. Don’t forget to bring friends! When you sign up for five or more tickets, you get an extra 20% discount on conference passes. Learn more now.

Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Cannot find Macro Googleanalytics when uploading workflow on the server

8 - Asteroid

hi folks, 


we are having trouble on uploading a workflow in the Gallery which has Google Analytics. 
It run fine locally but when uploaded it return these error. 
Cannot find Macro Googleanalytics_v8.0.0\Supporting Macros\Google_Analytics.yxmc

Do you kindly know or point out any steps/documentation please? 
We have installed the related tool in the server too.




14 - Magnetar

Hi @lzanotti, you need to get those macros installed on the Server machine. Please contact the Server admin and mention the macros that you need to get installed. 

5 - Atom

Hi, I work with @lzanotti, one of the issues we are having is that we have asked the IT department to install the GA tool v8 onto the server which they have confirmed has been done.


The trouble is that we are still getting the same error when uploading the workspace onto the gallery. Is there any documentation on how it needs to be installed onto the server that we could pass on to the IT department or any advice we can pass onto the IT team will be appreciated.

14 - Magnetar

You need to make sure to install it as admin for all the users. You can follow this article: https://help.alteryx.com/current/server/install-custom-tools 

8 - Asteroid

thanks @gabrielvilella , your suggestion implemented by our IT dept. had worked indeed.