Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Dynamic Input Not Producing Results

11 - Bolide

I have a strange issue wherein a valid file path is being sent to a Dynamic Input tool from a custom tool, but nothing comes out and there are no errors.  I tried a simple text input with the same path going into a Dynamic Input and it worked perfectly.  I also created a macro to accept the path from my custom tool and update a standard input tool, but that didn't work either.  What is the trick to getting a Dynamic Input/macro input to read a path string from a custom tool?





13 - Pulsar
13 - Pulsar

Hey Rick! 


Can I see an example of the path that is being pushed to the dynamic input tool? 


Also a weird side question, are you running this on the desktop or server/gallery?

Treyson Marks
Managing Partner
DCG Analytics
11 - Bolide

Hi Treyson,


Here is the path I'm passing in:  \\<servername>\<username>\My Documents\Test Integration Files\Sample - Superstore Sales (Excel).xls|Orders$


The results from text input/custom input are as follows (the path and all settings are exactly the same):


2017-06-19_Dynamic Input Issue.png

11 - Bolide

Figured it out.  I had created a second output stream in my tool, but neglected to close the second output helper object after passing all of the records through it.

7 - Meteor

I'm having the same problem and I cannot get it to work. Can you help me understand what your fix was? I have 1 input into the dynamic input. I've tried it a few ways.


I'm inputting a script then altering the data then using dynamic input to query against the results. Text input works fine; same data set. I use this dynamic input script all the time.


Any help appreciated!