Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Alteryx 11 Performance Issues

Highlighted
Alteryx Alumni (Retired)

Hi Everyone,

 

Thank you for reporting this issue and providing extra details.  We have been able to track the issue down and are planning on releasing an update that resolves the problem.  I will post again once that is available.  I am expecting to have an update by the end of next week.

 

The problem we found was related to internet connectivity.  The feature works really well either with full internet access or with none at all.  The problem occurred when there was indeterminate internet connectivity.  In this scenario we were waiting for a timeout on the connection before continuing.  Apologies to anyone that was affected and we will get this updated for you soon.

 

Best Regards,
Ben

Highlighted
Atom

Yeah this makes 11 unusable over VPN. Wasted so much time waiting for timeouts while trying to view sample data sets to build formulas. 10 worked beautifully for me over VPN. I can't hardly wait for this update. Thanks for responding and find the issue so quickly.

 

Thanks,

Michael

Highlighted
Meteor

Hi Ben,

 

I have Alteryx 11 installed on a server with absolutely no access to the 'outside world' and having the following two issues while RDP in to that server.

 

1) Launching Alteryx takes about 2 minutes.  The server is quite beefy with very little activity, so I would expect it to launch in seconds not minutes.

2) Clicking on "search" and typing even 1 character pauses the entire window for about 2 minutes.

 

I just wanted to make both of these are being addressed, since you mentioned the problems did not occur on machines with no internet access.

 

Thanks,

 

Scott

Highlighted
Alteryx Alumni (Retired)

Yes, the issue that you are describing matches the performance issues we were seeing and will be fixed in the near future.  

 

Thanks,

Ben

Highlighted
Meteor

Thanks Ben!!

 

Scott

Alteryx Partner

I have an issue which is related to this topic, but not with the search tool but moving tools around or renaming tool container.

When typing in the name of the container, I can literally watch how each letter is appearing, it takes roughly a second per later ... pretty annoying. 

 

I guess fixing the issues with the internet connection won't help in my case ...

 

Cheers Tom

Highlighted
Pulsar
Pulsar

Yesterday I installed 11.0.5.26351 to fix the 32-bit ODBC issue (known issue).  Both yesterday, and today, my designer has stalled for up to 30 - 60 seconds, sporadically (about 6 times total).  The last three times I really paid attention, and each time it was because I was either accessing the formula tool, or moving it around the canvass.  I know in beta testing the formula tool had performance issues, and they seemed to be fixed as best as possible with the official release (although those of us used to the instantaneous response of the old formula tool will notice the difference).  Not sure if it's just me having the issue or not.  

Highlighted

By any chance, have you tried disabling the Data Profiling option?

I'm on 11.0.5.26351 also - seemed to improve performance.

Highlighted
Pulsar
Pulsar

Yes, but not until after that 6th time yesterday.  Hasn't happened since, but I went home shortly after.  We'll see how it goes today with that turned off.  

Highlighted
Pulsar
Pulsar

It did happen twice already today.  I'll go along as normal.  If it's still an issue by early next week, I'll just revert back to 10.6 until more bugs are worked out.

Labels