Looking for Starter Kits? Head to the Community Gallery! Now formatted as YXIs for easy installation.

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Macro wont open. "Question tool load error, tool id missing associated question data"

9 - Comet

Had a spot of bother.... tried to run a workflow with a macro in it but got the above error.


alteryx errors message.PNG

I have tried to open macro directly through file explorer and alteryx open dialogue to no avail. Just flashes error dialogue and then fails to open on clear.


Have tried dragging it on to a an empty new workflow tab, and it seems to open a tab, but wont display any of the tools or settings. Worse still as i try to close the other blank new workflow tab, it just iterates up a number with each close.eg new workflow2, new workflow 3 etc etc


Seems very wrong to me.


There have been no changes since last successful run, but it seems corrupted somehow. I have upgraded the version since. Coudl that be the issue.


Any help much appreciated.


many thanks





11 - Bolide

Hey @warrencowan,


Can you open the macro by right-clicking on it in your workflow and going to 'Open Macro...' rather than through file explorer? 



9 - Comet

sorry @mmenth shouldve said, that was my first step, and it triggered the same error.

7 - Meteor

Hi If not already figured out - Just Open the yxmc file and look for your node number and delete the whole node section. I had same error with node 97 and deleted below section and saved - I recovered the file.


Hope this helps!


<Node ToolID="97">
<GuiSettings Plugin="AlteryxBasePluginsGui.MacroInput.MacroInput">
<Position x="306.0001" y="485.0003" />
<UseFileInput value="False" />
<Abbrev />
<ShowFieldMap value="False" />
<Optional value="True" />
<NumRows value="1" />
<Field name="Mystuff" />
<Annotation DisplayMode="0">
<Name />
<DefaultAnnotationText />
<Left value="True" />
<MetaInfo connection="Output">
<Field name="Mystuff" size="57" source="TextInput:" type="String" />
<EngineSettings EngineDll="AlteryxBasePluginsEngine.dll" EngineDllEntryPoint="AlteryxMacroInput" />

5 - Atom

Thanks. Deleting Node solved it!


Next time you get that error, check below article:

How To Troubleshoot "A question tool is missing the associated question data"