Happy 8th birthday to the Maveryx Community! Take a walk down memory lane in our birthday blog, and don't miss out on the awesome birthday present that all Maveryx Community members get to take advantage of!

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Email tool fails to send with attachment: Failure when receiving data from the peer

8 - Asteroid



I have a workflow that works fine and sends an email without an attachment but as soon as I add the attachment I get the error "Failure when receiving data from peer".


Can anyone please help?  I looked at prior postings and I believe my SMTP settings are OK as I am able to send without the attachment.  Please let me know if there is something I can try.








18 - Pollux

This is probably network/vpn related - there are some posts related to this error here:

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/Failure-when-receiving-data-from-the-p... and other places.


A few quick questions - are you attaching a file you are generating in workflow? Is it on a network drive? Can you confirm that path you are generating to the file is accurate (ie the correct path)...  Your attachment is blurred out - but I usually use that section to tag a field which has the specific path of the attachment. I find that's cleaner.


One more question - I notice this is SAP goodness - are you using DVW - if not - you should be.

8 - Asteroid

Thanks for the quick response! The file is local but it is generated from the workflow (I put several "Block Until Done" to make sure that the files should be complete prior to sending).  I selected the path/file directly from the "Attachments" box (see below).  As for SAP, it does feed to our customer's system but they upload it manually (not sure what DVW is), I just create the data for them and they take it from there, I just wanted to not have to manually email it. :-)    Thanks again.




8 - Asteroid

I also tried sending a file that was not in the workflow to see if the data being written to the file was an issue and it gave me the same error (Failure when receiving data from the peer).  I tried the throttle tool (mentioned in the link to other fixes) as well and that also did not fix the issue.

18 - Pollux

hmmm. this might be an issue with the encryption and permissions. Can you try dummy file?


create  a formula tool before your output data - filename - and the formula should be [Engine.WorfklowDirector]+"test.csv" - replace your full path with it.


now go to your e-mail tool -  toggle your attachment selection to file name from field value (and then select the filename field)..


if that gives you the same error it's probably on the security side.

8 - Asteroid

I figured it out! My issue was the name of the file itself.  DO NOT USE SPACES IN THE FILENAME!  I used underscores instead of spaces in the name and it corrected the issue.  Oddly, the file path can have spaces but the filename itself triggers the error.

13 - Pulsar

@frank6773 Nice spot


5 - Atom

Late to reply here, but wanted to comment in case anyone else comes across this error. I found that not using spaces in the filename worked for me as well. AND not using commas in the filename as well. Just used regex replace and took commas out.