community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx connect Discussions

Find answers, ask questions, and share expertise about Alteryx Connect.
SOLVED

XLS export functionality hindering bulk upload options

Asteroid

2018.2...We are finding that we are unable to export to excel (xls) via the ellipsis top right. Everyone who has tried this in our org, has received a "File Corrupted / unable to open" error message. No matter the section(Glossary, Reports, etc), we are unable to successfully export via this method. It is not linked to an .xls issue as we are able to download to .xls from the "All Terms" or "All Reports" sections (mid page sections).

 

We've seen this issue vaguely referenced here, and no direct solution provided. 

"Using a workaround due to the known issue with the Glossary export functionality we have succesfully output a Glossary.xls and uploaded/imported rows."

 

Anyone else experience this? Have insight into the issue and/or provide a workaround? We were really counting on the import functionality to bulk load our Glossary and have hit a brick wall with this. 

 

 

Alteryx
Alteryx

Hi @NoSass

 

could you please provide any printscreen of what ellipsis menu you are talking about? I just tried the Export to XLS on several different pages and they all seem to be working for me. 

Also, 18.2 is quite an old version, so it is possible it has been already fixed meanwhile. 

 

 

Vojta T., PM for Connect
Asteroid

Connect example extract.jpg

 

Red arrow creates errors/corrupted files, Green arrow is able to export and open w/o issue. It's the red arrow that is referenced in all documentation relating to bulk exporting/importing. 

Alteryx
Alteryx

I know there was this issue and I believe it has been resolved already. 

Here is my successful attempt on 2019.1 version. 

 

So I believe the upgrade should solve your issue.

 

Screencast 2019-03-13 at 2.45.39 PM.gif

Vojta T., PM for Connect
Asteroid

@VojtechT  Does Connect have backwards compatibility with Server & Designer? Can we upgrade just Connect to a newer(>18.2) version while keeping Server on 18.2?

 

Alteryx
Alteryx

Hi @NoSass,

in general, there is only one thing in Connect dependent on Designer/Server and that is running loaders straight from Connect.

In 2018.2 this was possible only for the Alteryx loader, so I guess you are probably not using it and therefore the upgrade shouldn't be any issue here.

 

But what might be an issue are the loaders. You couldn't upgrade loaders to 19.1 as you will not be able to run them in Designer, because those workflows are made in Designer 18.4 and require new tools added in 19.1. (The tools can be delivered separately but the Designer will probably not let you run workflows made by a higher version.)

 

So, the option would be to keep using 18.4 loaders and load the metadata into 19.1. Most of the changes we've done were about adding, not modifying, so generally speaking it could work, but we are not testing all possible combinations, so officially such scenario is not supported. Bud depending on which loaders you are using it might work or not. 

I don't think there is any other way to find that out other than try it. 

If you can afford to have Connect some time down, you can just stop the service, rename/copy the folder, install 19.1, try to run your 18.4 loaders and the rollback in case of needed should be easy as renaming the original folder back again. 

Vojta T., PM for Connect