Weekly Challenges

Solve the challenge, share your solution and summit the ranks of our Community!

Also available in | Français | Português | Español | 日本語

Want to get involved? We're always looking for ideas and content for Weekly Challenges.


Weekly Challenge Index & Welcome (Page 1)

8 - Asteroid



The SSL connect error means that you are not pointing the URL to the correct web page.  I'm not sure what you're pointing to in the text input in front of the download tool, but the part of the web link that shows in your screenshot is not correct.  


You need two input streams:




The text input in the first one needs to be this url, which was in the original workflow (https://community.alteryx.com/t5/Weekly-Challenge/Weekly-Challenge-Index-amp-Welcome/td-p/48275?):




The second text input needs to be this url (https://community.alteryx.com/t5/Weekly-Challenge/Weekly-Challenge-Index-amp-Welcome-Page-2/td-p/113...): 




Copy the original set of tools up to the second regex tool to create the second input stream.  Then the regex outputs of both streams need to be unioned together.  The union tool that combines the results of the first regex in both streams connects as the left input of this tool:



The union tool that combines the results of the second regex in both streams connects as the Replace input of this tool:




Then it should work.

8 - Asteroid

The workflow that I downloaded does not have union tools because it is probably for the first 300 ones.






I already tried the links you gave me in the text input, the one with "?" at the end at one without.




And I put my username.


It's still giving me SSL connect error.


8 - Asteroid



That is correct.  The downloaded one does not have union tools.  You have to create the second stream in this container to include challenges 301 - current.




The SSL error is related to the url in the text input.  It can't read it, so something is either wrong with the url, or the configuration of the Download tool.


I attached mine.  If I change the username to yours, it works without fail.







5 - Atom

This has been great!! tried my hands on ..its good to get your hands dirty to practice tons of it

8 - Asteroid

Since we upgraded to 2023.1 this workflow does not work for us too: same error message on the download tool as @hlee36 . @tammybrown_tds your version does not work as well...

8 - Asteroid

@Linas, I am not sure if the Alteryx version has anything to do with it...it shouldn't.  I'm still on 2020.1, so I can't verify the Alteryx version being a problem.  But I ran my version of the workflow with your username and it ran just fine.  You've completed 52 challenges.


Can you reply with the version of your workflow that doesn't work and I'll see if it works for me on 2020.1?

7 - Meteor

Hi, I've done 5 or so of these over the past couple of weeks and I don't seem to be getting any credit for them, am I doing something wrong?

16 - Nebula
16 - Nebula

@CMatador If you're attaching your workflows, then probably not. It looks like the table hasn't been updating for the last month or so.

8 - Asteroid

@CMatador @PhilipMannering yea, I've contacted Alteryx, they've been having issues with tracking. I completed over 30 in the last 30 days and haven't gotten any badges or showing up on the 30 day board. 

8 - Asteroid

I have done all challenges and that's what i see with the adequate workflow. However, this is not what i can see in the summary. Do you know why?