Welcome to the Gallery. Please feel free to post and comment, and check out our FAQ!

Community Gallery

Post, download, and share all of your favorite tools and workflows — from Alteryx supported to user-built.
Introducing Alteryx Marketplace

Easily access verified, supported, and secure Add-Ons.

6 - Meteoroid

@AlteryxProducts , The Issue persists:


I have a call tomorrow with support to check it out.


Version: 2021.3.3.63061





6 - Meteoroid

Does it works for you? I am trying to use it.

6 - Meteoroid



  1. First you need to setup the application on azure as the documentation: https://help.alteryx.com/20213/designer/microsoft-onedrive 
  2. Install the most updated onedrive add on;
  3. Create the registry as bellow: (According to alteryx support this registry step wont be necessary on new version (2021.4 / 22.1). Let's see.)
    1. I 'am using the 2021.3.3 version;
    2. You must be admin privileges;
    3. The PythonAllowHideEncryption key must be set on each user’s machine, as well as on all Worker nodes. Worker nodes must also have the tools (in this case, Sharepoint Files Input) installed.  The process is the same for a non-Admin install on the user's machine as it is for an Admin install.
      1. Create Key
      Administrators will need to create a new string value PythonAllowHideEncryption under the Alteryx Registry Key:

      1. Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\SRC\Alteryx
        Value Name: PythonAllowHideEncryption
        Value Data: true
      2. Steps to create the new key:
        1. Type regedit in Windows Start Menu
        2. Browse to the folder location: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\SRC\Alteryx
        3. Right click and select New > String Value
        4. Set the KeyName to PythonAllowHideEncryption and the Value to true
      2. Gallery Interaction Changes
      The below descriptions assume that all users interacting with the Gallery have the registry key set to true.
      a. Uploading to Gallery: Encrypted values for the supported Python tools will be updated to a hide encryption once you publish to the Gallery.
      b. Running on Gallery: Only workflows that originated from machines with the registry key set will be able to run successfully on the Gallery. The worker nodes must also have the registry key set and the respective Python tools installed.
      c. Opening from Gallery: The original encryption method will be restored. These Python based tools might need to be reconfigured in order for the workflow to run.

      Once you've added the registry key to the local machine, server machine, and any worker nodes, you'll want to reauthenticate the tool.  
5 - Atom

I keep getting this error when trying to install it - any ideas as to how to resolve it? 





7 - Meteor

@andrewtcarlson  Have you found a solution yet? I'm having this issue as well but for the SharePoint tools. 

5 - Atom

Yeah, I'm getting the same issue with Sharepoint and OneDrive tools - same error & grpcio version number?  Any joy on a resolution??

8 - Asteroid

Same error installing to version 2020.2.3

5 - Atom

Hi, I could install the addin without problem. However, the login via Internet explorer is not working. Any Ideas?

BR Sebastian

6 - Meteoroid

I was unable to get this tool to work on Designer versions 2021.3 It installs, allows me to log in through the web but crashes designer when trying to save the tool settings.

5 - Atom

Hi everyone,
I have followed the guide from Alteryx: Microsoft OneDrive | Alteryx Help

And everything seems to have been done in the right way, however, whenever I try to log-in I get this error. Has anyone tried this before? 




9 - Comet

When I output to excel onto OneDrive my dates come out 70 years into the future.  Looks like this was a bug that was fixed in the SharePoint and Tableau output tools.  Is there a work around for this?


Update: Figured this one out myself.  This only happened to me for Date data type fields.  Not for DateTime.  I switched the Date fields to String and they come out not 70 years in the future.

11 - Bolide

I recently installed the most current version fo the OneDrive tool, and I am getting this error when I try to run after successfully connecting and referencing a CSV file. 


we are on Alteryx Designer 2022.1-- is that the issue? 


Error: OneDrive Input (3): local variable 'no_of_records' referenced before assignment


Seems like a python error. Any suggestions? download older version?

5 - Atom

Hello - I've recently installed the OneDrive tool, but seems that the Login via browser doesn't work, it keeps loading and nothing happens, it won't open any browser window. Has anyone had this issue before? How did you solve it? 

5 - Atom

I was using the onedrive tool input with the version 2.2.1 and I had the same issue :


Error: OneDrive Input (3): local variable 'no_of_records' referenced before assignment


When I was trying to understand the problem I discovered that my excel file had a configuration problem with the authenticator. So , I changed the file and  the tooll returns to work. 


Try to look the warning log when you run your workflow to see if there is some problem with the file. 



8 - Asteroid

OneDrive v2.2.1 when trying to setup DCM, no technology available to select from, thus unable to run on server, anyone has this issue and is there a workaround?

8 - Asteroid

I have Sucessfully connected, DCM With one drive. Can you plese revert error what you get in details then I am ready to help. for bo_peng2022