alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
Check out our powerful new search update! You can read more here. Please let us know if you have any feedback by creating a topic here.

Workflow works different in Gallery


Hello team!


I'm having different results running my workflow locally and from gallery. Basically what it does is it takes data from CSV file, converts it into a proper JSON string and POSTs it using Download Tool.


When I run my workflow locally it transfers all the records it can find in SCV file. As soon as I process it through gallery it only sends 1 record, though it actually gets the total quantity of records from the file.


Here is the example of processing the same file with 4 records:

This is the local report:


This is the gallery:



Can anyone advice where the issue is hiding?


Thank you in advance!


Do you have anything taking place after the download tool?


If not I'd recommend adding a few tools (select and browse maybe) as it could be that not all the data is past to the download if there is nothing after it.


Hi JoeS,


Thanks a lot for your reply!


No I didn't have anything setup after. I followed your suggestion and added select and browse, but it didn't change the picture.


When I run the workflow locally it processes all the records from file, as soon as I upload the workflow and run it from gallery, only first record is getting processed.


Could you add output tools after bother the dynamic input and the download tool.


If you check the output after the dynamic input, does it have the same rows that you get when run in designer.

And if you check the output from the download tool, do you get any insight into what's happened there?


Hello JoeS,


I decided to use a batch macro to process every single record from the file. But after I added it I still had the same issue..


Then I was looking for solution specifically for macro and found Batch Macro not looping after running the workflow as an analytic app topic where solution for my macro was simple - removing the output


Now the issue is solved!


Thanks a lot for your help!