alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

Call my own Workflow Applcation from my own Alteryx-Server from different locations on my

Highlighted
Alteryx Partner

 

privat network.

 

 

Hi!

I want to use our own Alterxy Server Gallery  with our own published workflows.

 

To test whether...
I installed Alteryx Server into a created virtual maschine. I use VMWare Workstation 12 Player.
The OS of the VM is a Window 7 Home Basic. The host Windows 7 Home Premium. I did not have a Windows Server installation yet.

The network adapter of the VM is NAT. The VM is connected to the Internet.

Now I want to connect from my Host to the VM.

In other word I want to call our Alteryx Server Gallery from my Host via a webbrowser.

On my VM I call it via webbrowser with http://localhost/gallery/ or http://<IP-Address VM>/gallery/

But when I try this http://<IP-Address VM>/gallery/ from Host I get an connection error.

I thought that the Alterxy Server installed a webserver too. But if I call only http://localhost. I get an error.

There is no installed webserver, or?

It seams like a Javascript application.

Who is the entry in my Windows 7 that allowed to call http://localhost/gallery/ without a installed webserver.


What am I doing wrong or better how do I do right.


Is there any tutorial?

Mathias   

Highlighted
13 - Pulsar
13 - Pulsar
Can you send a screenshot of the actual connection error message?
Highlighted
Alteryx Partner

Hey this is the error message

 

error_bridge_connection.JPG

 

Any idea? It will be great!

 

Mathias

Highlighted
13 - Pulsar
13 - Pulsar

That's a VMware setting.  Check the vmnet0 (the default bridged network).  It should be set to a dedicated physical adapter, not 'automatic'.

Alteryx Partner

Thank you for your support.

 

 

Now it works!!!!

 

 

Your suggestion:

 

That's a VMware setting.  Check the vmnet0 (the default bridged network).  It should be set to a dedicated physical adapter, not 'automatic'.

 

Does not help

 

 

A bout the desperation of trying. What did I do. I have made a system restore. And now I am able to create a VM with a bridge connection.

 

network_connection.JPG

 

scrennshot_ipconfig.JPG

 

 :manvery-happy:

 

Mathias